summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-28 18:26:25 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-29 09:14:28 +0100
commitf29a28bb1af16b582c7e8cc3311d64e850424ec3 (patch)
treea96dbd865e367abd580ecb573497945b28957950 /app-portage/esearch
parentpackage.mask: Last rite dev-python/astropy & revdeps (diff)
downloadgentoo-f29a28bb1af16b582c7e8cc3311d64e850424ec3.tar.gz
gentoo-f29a28bb1af16b582c7e8cc3311d64e850424ec3.tar.bz2
gentoo-f29a28bb1af16b582c7e8cc3311d64e850424ec3.zip
app-portage/esearch: Replace python_export_best
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/esearch')
-rw-r--r--app-portage/esearch/esearch-1.3-r2.ebuild10
-rw-r--r--app-portage/esearch/esearch-9999.ebuild11
2 files changed, 9 insertions, 12 deletions
diff --git a/app-portage/esearch/esearch-1.3-r2.ebuild b/app-portage/esearch/esearch-1.3-r2.ebuild
index c7d538437df6..f2e2ee6be360 100644
--- a/app-portage/esearch/esearch-1.3-r2.ebuild
+++ b/app-portage/esearch/esearch-1.3-r2.ebuild
@@ -29,17 +29,15 @@ PATCHES=(
"${FILESDIR}"/${PV}-Fix-python-3-compatability.patch
)
-python_prepare_all() {
- python_export_best
- echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
- VERSION="${PVR}" "${PYTHON}" setup.py set_version \
+python_configure_all() {
+ echo VERSION="${PVR}" "${EPYTHON}" setup.py set_version
+ VERSION="${PVR}" "${EPYTHON}" setup.py set_version \
|| die "setup.py set_version failed"
- distutils-r1_python_prepare_all
}
python_install_all() {
distutils-r1_python_install_all
- dodoc eupdatedb.cron || die "dodoc failed"
+ dodoc eupdatedb.cron
# Remove unused man pages according to the l10n flags
if ! use l10n_fr ; then
diff --git a/app-portage/esearch/esearch-9999.ebuild b/app-portage/esearch/esearch-9999.ebuild
index d3487f839a86..10b62a631ed8 100644
--- a/app-portage/esearch/esearch-9999.ebuild
+++ b/app-portage/esearch/esearch-9999.ebuild
@@ -21,16 +21,15 @@ KEYWORDS=""
DEPEND="sys-apps/portage"
RDEPEND="${DEPEND}"
-python_prepare_all() {
- python_export_best
- echo VERSION="9999-${EGIT_VERSION}" "${PYTHON}" setup.py set_version
- VERSION="9999-${EGIT_VERSION}" "${PYTHON}" setup.py set_version
- distutils-r1_python_prepare_all
+python_configure_all() {
+ echo VERSION="${PVR}" "${EPYTHON}" setup.py set_version
+ VERSION="${PVR}" "${EPYTHON}" setup.py set_version \
+ || die "setup.py set_version failed"
}
python_install_all() {
distutils-r1_python_install_all
- dodoc eupdatedb.cron || die "dodoc failed"
+ dodoc eupdatedb.cron
# Remove unused man pages according to the l10n flags
if ! use l10n_fr ; then