summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-18 10:25:46 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-18 10:55:34 +0100
commit2c7c7801635372442527176da5bf6f86f0034642 (patch)
tree3c15597fa80b19f483c14ca9a6118ddc15490c63 /app-portage/gemato
parentapp-arch/unrar: Removed old (diff)
downloadgentoo-2c7c7801635372442527176da5bf6f86f0034642.tar.gz
gentoo-2c7c7801635372442527176da5bf6f86f0034642.tar.bz2
gentoo-2c7c7801635372442527176da5bf6f86f0034642.zip
app-portage/gemato: Enable py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gemato')
-rw-r--r--app-portage/gemato/gemato-14.3.ebuild3
-rw-r--r--app-portage/gemato/gemato-9999.ebuild7
-rw-r--r--app-portage/gemato/gemato-9999m.ebuild7
3 files changed, 7 insertions, 10 deletions
diff --git a/app-portage/gemato/gemato-14.3.ebuild b/app-portage/gemato/gemato-14.3.ebuild
index d58a025ed50f..317b969b3e5e 100644
--- a/app-portage/gemato/gemato-14.3.ebuild
+++ b/app-portage/gemato/gemato-14.3.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-# pysha3 is broken with pypy3
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} pypy{,3} )
PYTHON_REQ_USE='threads(+)'
inherit distutils-r1
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index f419059fa647..ec43603da332 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# pyblake2 & pysha3 are broken with pypy3
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} pypy{,3} )
PYTHON_REQ_USE='threads(+)'
inherit distutils-r1 git-r3
@@ -24,7 +23,7 @@ MODULE_RDEPEND="
bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
gpg? ( app-crypt/gnupg )
lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
- sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )"
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy) )"
RDEPEND="${MODULE_RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/app-portage/gemato/gemato-9999m.ebuild b/app-portage/gemato/gemato-9999m.ebuild
index fe7b3b5ba969..abe4544cbdaa 100644
--- a/app-portage/gemato/gemato-9999m.ebuild
+++ b/app-portage/gemato/gemato-9999m.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-# pyblake2 & pysha3 are broken with pypy3
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} pypy{,3} )
PYTHON_REQ_USE='threads(+)'
inherit distutils-r1 git-r3
@@ -25,7 +24,7 @@ MODULE_RDEPEND="
bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
gpg? ( app-crypt/gnupg )
lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
- sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )"
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy) )"
RDEPEND="${MODULE_RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"