summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-portage/gentoolkit-dev/gentoolkit-dev-0.3.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-portage/gentoolkit-dev/gentoolkit-dev-0.3.0.ebuild')
-rw-r--r--app-portage/gentoolkit-dev/gentoolkit-dev-0.3.0.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/app-portage/gentoolkit-dev/gentoolkit-dev-0.3.0.ebuild b/app-portage/gentoolkit-dev/gentoolkit-dev-0.3.0.ebuild
new file mode 100644
index 000000000000..c814f13fdc4c
--- /dev/null
+++ b/app-portage/gentoolkit-dev/gentoolkit-dev-0.3.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/gentoolkit.git
+ http://anongit.gentoo.org/git/proj/gentoolkit.git"
+ EGIT_BRANCH="gentoolkit-dev"
+else
+ SRC_URI="http://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Collection of developer scripts for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+CDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+ dev-lang/perl
+ sys-apps/diffutils"
+DEPEND="${PYTHON_DEPS}
+ test? ( ${CDEPEND} )"
+RDEPEND="${PYTHON_DEPS}
+ ${CDEPEND}"
+
+src_prepare() {
+ if [[ -n ${EPREFIX} ]] ; then
+ # fix shebangs of scripts
+ local d p
+ ebegin "Fixing shebangs"
+ for d in src/* ; do
+ p=${d#*/}
+ sed -i \
+ -e "1s:\(\(/usr\)\?/bin/\):${EPREFIX}\1:" \
+ ${d}/${p}* \
+ || die "failed to fix ${d}/${p}"
+ done
+ eend $?
+
+ # fix repo location
+ sed -i \
+ -e "s:portage\.db\['/'\]:portage.db['${EPREFIX}/']:g" \
+ src/ekeyword/ekeyword.py \
+ || die "failed to set EPREFIX in ekeyword"
+ fi
+}
+
+src_test() {
+ # echangelog test is not able to run as root
+ # the EUID check may not work for everybody
+ if [[ ${EUID} -ne 0 ]]; then
+ python_foreach_impl emake test
+ else
+ ewarn "test skipped, please re-run as non-root if you wish to test ${PN}"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ python_replicate_script "${ED}"/usr/bin/{ekeyword,imlate}
+}