summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-30 17:32:29 +0100
committerMichał Górny <mgorny@gentoo.org>2019-10-30 17:34:45 +0100
commit6b2f88fb03a37c48fc50d9fa008f2e3085831916 (patch)
tree89d4a88bd90f4b764f29e2fc90b5242025a903c4 /app-portage/gverify/gverify-2.ebuild
parentapp-crypt/openpgp-keys-gentoo-auth: Package the Authority Keys (diff)
downloadgentoo-6b2f88fb03a37c48fc50d9fa008f2e3085831916.tar.gz
gentoo-6b2f88fb03a37c48fc50d9fa008f2e3085831916.tar.bz2
gentoo-6b2f88fb03a37c48fc50d9fa008f2e3085831916.zip
app-portage/gverify: Bump to v2
v2 switches to using Authority Keys and therefore stops failing due to obsolete gkeys seeds. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/gverify/gverify-2.ebuild')
-rw-r--r--app-portage/gverify/gverify-2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/gverify/gverify-2.ebuild b/app-portage/gverify/gverify-2.ebuild
new file mode 100644
index 000000000000..18068b633e4c
--- /dev/null
+++ b/app-portage/gverify/gverify-2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit python-single-r1
+
+DESCRIPTION="gentoo.git signature verification tool"
+HOMEPAGE="https://github.com/mgorny/gverify"
+SRC_URI="https://github.com/mgorny/gverify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+ app-crypt/gnupg
+ app-crypt/openpgp-keys-gentoo-auth
+ dev-vcs/git"
+DEPEND="${PYTHON_DEPS}"
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr
+ dodoc README
+}