summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-23 09:06:50 +1000
committerSam James <sam@gentoo.org>2022-07-23 01:51:46 +0000
commite4684c82feea45c1abccd371c3e82480529f006e (patch)
treef48614a6807a2c9a6bb4ae319787e75fe82e8550 /app-portage/hackport
parentapp-portage/hackport: drop 0.6.6, 0.7 (diff)
downloadgentoo-e4684c82feea45c1abccd371c3e82480529f006e.tar.gz
gentoo-e4684c82feea45c1abccd371c3e82480529f006e.tar.bz2
gentoo-e4684c82feea45c1abccd371c3e82480529f006e.zip
app-portage/hackport: refresh live ebuild
Signed-off-by: Jack Todaro <solpeth@posteo.org> Closes: https://github.com/gentoo/gentoo/pull/26528 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage/hackport')
-rw-r--r--app-portage/hackport/hackport-9999.ebuild76
1 files changed, 43 insertions, 33 deletions
diff --git a/app-portage/hackport/hackport-9999.ebuild b/app-portage/hackport/hackport-9999.ebuild
index 6853550d5f1f..7cc74ec9ca0f 100644
--- a/app-portage/hackport/hackport-9999.ebuild
+++ b/app-portage/hackport/hackport-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-# ebuild generated by hackport 0.5.1.9999
+# ebuild generated by hackport 0.7.1.1.9999
+#hackport: flags: +cabal-v1
CABAL_FEATURES="test-suite"
EGIT_REPO_URI="https://github.com/gentoo-haskell/hackport.git"
@@ -13,47 +14,56 @@ inherit git-r3 haskell-cabal
DESCRIPTION="Hackage and Portage integration tool"
HOMEPAGE="https://github.com/gentoo-haskell/hackport"
-LICENSE="GPL-2"
+LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-IUSE=""
-RESTRICT=test # tests are broken: need path to ebuild tree
-
-RDEPEND="
- app-portage/repoman
- dev-haskell/async:=
- dev-haskell/base16-bytestring:=
- dev-haskell/base64-bytestring:=
- dev-haskell/cryptohash:=
- dev-haskell/ed25519:=
+RDEPEND=">=dev-haskell/async-2.0:=
+ >=dev-haskell/base16-bytestring-0.1.1:=
+ >=dev-haskell/base64-bytestring-1.0:=
+ >=dev-haskell/cryptohash-sha256-0.11:=
+ >=dev-haskell/echo-0.1.3:=
+ >=dev-haskell/ed25519-0.0:=
+ >=dev-haskell/edit-distance-0.2.2:=
dev-haskell/extensible-exceptions:=
- dev-haskell/hashable:=
- >=dev-haskell/http-4000.0.3:=
- dev-haskell/missingh:=
- dev-haskell/mtl:=
- >=dev-haskell/network-2.6:=
- >=dev-haskell/network-uri-2.6:=
- dev-haskell/old-locale:=
- dev-haskell/old-time:=
- dev-haskell/parsec:=
- dev-haskell/random:=
- dev-haskell/regex-compat:=
+ >=dev-haskell/hashable-1.0:=
+ >=dev-haskell/http-4000.1.5:=
+ >=dev-haskell/network-3.0:=
+ >=dev-haskell/network-uri-2.6.0.2:=
+ >=dev-haskell/parallel-3.2.1.0:=
+ dev-haskell/quickcheck:2=
+ >=dev-haskell/random-1:=
+ >=dev-haskell/regex-base-0.94.0.0:=
+ >=dev-haskell/regex-posix-0.96.0.0:=
+ >=dev-haskell/resolv-0.1.1:=
dev-haskell/split:=
- dev-haskell/stm:=
- >=dev-haskell/tar-0.5:=
- >=dev-haskell/xml-1.3.7:=
- dev-haskell/zlib:=
- >=dev-lang/ghc-7.8.2:=
+ >=dev-haskell/stm-2.0:=
+ >=dev-haskell/tar-0.5.0.3:=
+ dev-haskell/xml:=
+ >=dev-haskell/zlib-0.5.3:=
+ >=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.18.1.3
- test? ( dev-haskell/hunit )
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/base-compat
+ dev-haskell/cabal-doctest
+ >=dev-haskell/doctest-0.8
+ dev-haskell/glob
+ >=dev-haskell/hspec-2.0
+ >=dev-haskell/quickcheck-2.0 )
+"
+RDEPEND+="
+ dev-util/pkgcheck
"
src_prepare() {
default
- sed -e 's/^Version:.*/&.9999/' -i ${PN}.cabal || die # just to distinct from release install
+ sed -e 's/^Version:.*/&.9999/' -i ${PN}.cabal || die # just to distinguish from release install
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=cabal-v1
}
src_install() {