summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-03-16 10:02:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-03-16 10:21:06 -0400
commitfcdde1d0bc3279dacc5bf25aed059b8b40b1efef (patch)
treec4d71462bd520c245b7d0c854819e74d721f80e8 /app-portage/iwdevtools/iwdevtools-0.10.1-r2.ebuild
parentwww-client/chromium: stable channel bump to 99.0.4844.74 (diff)
downloadgentoo-fcdde1d0bc3279dacc5bf25aed059b8b40b1efef.tar.gz
gentoo-fcdde1d0bc3279dacc5bf25aed059b8b40b1efef.tar.bz2
gentoo-fcdde1d0bc3279dacc5bf25aed059b8b40b1efef.zip
app-portage/iwdevtools: backport diff output fix
Another short fix, leaving releases for later and going straight to stable. Kind of important fix, in some rare'ish cases a line may not have been displayed leading to missed information. So new output may be available. Thanks-to: Joonas Niilola <juippis@gentoo.org> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools/iwdevtools-0.10.1-r2.ebuild')
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.10.1-r2.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/iwdevtools-0.10.1-r2.ebuild b/app-portage/iwdevtools/iwdevtools-0.10.1-r2.ebuild
new file mode 100644
index 000000000000..c4d90017aac1
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.10.1-r2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv sparc x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ldpath-regression.patch
+ "${FILESDIR}"/${P}-diff-off-by-one.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}