summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-17 11:20:53 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-17 11:22:33 -0400
commit26e3a8b26b24c55b44674bab5af10ef3da0411d0 (patch)
treea137066ac52fe481395668de44232509fdba2511 /app-portage/iwdevtools
parentprofiles: last-rite sys-fs/e4rat (diff)
downloadgentoo-26e3a8b26b24c55b44674bab5af10ef3da0411d0.tar.gz
gentoo-26e3a8b26b24c55b44674bab5af10ef3da0411d0.tar.bz2
gentoo-26e3a8b26b24c55b44674bab5af10ef3da0411d0.zip
app-portage/iwdevtools: add 0.1.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
new file mode 100644
index 000000000000..c30ffe85895a
--- /dev/null
+++ b/app-portage/iwdevtools/Manifest
@@ -0,0 +1 @@
+DIST iwdevtools-0.1.0.tar.gz 16082 BLAKE2B 941ed5436be9579c1a1e96a032e8122f67f74b5449713be474dda443fa983759c61a8a19f846fc0e6d04e8ef757efbacc4a058fe1c27c0ec91029587bb0ac6a0 SHA512 7a26e59d8707fab80a0a234c294f100f75f411fce2e0f12bc1c5b4c134aaaa9c878d405e77a0cf88119681841a9bf4b98662bb729fda50bb7ca5bcea025a2fca
diff --git a/app-portage/iwdevtools/iwdevtools-0.1.0.ebuild b/app-portage/iwdevtools/iwdevtools-0.1.0.ebuild
new file mode 100644
index 000000000000..8886d7139126
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ sys-apps/util-linux"
+
+src_configure() {
+ meson_src_configure -Ddocdir=${PF}
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To (optionally) integrate with portage, inspect the .bashrc files installed"
+ elog "at ${EROOT}/usr/share/${PN}. If not already using a bashrc, you can use"
+ elog "the example bashrc directly by creating a symlink:"
+ elog
+ elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ fi
+}