summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-02 21:56:10 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-02 21:58:33 -0500
commit94ab9b4e8ed53bcb72217c78c78e75c035ee9c38 (patch)
treee79e22c9cfa70cde6a336f980e13edf72f2d93b1 /app-portage/iwdevtools
parentmedia-libs/mesa: Require wayland-protocols-1.24 (diff)
downloadgentoo-94ab9b4e8ed53bcb72217c78c78e75c035ee9c38.tar.gz
gentoo-94ab9b4e8ed53bcb72217c78c78e75c035ee9c38.tar.bz2
gentoo-94ab9b4e8ed53bcb72217c78c78e75c035ee9c38.zip
app-portage/iwdevtools: add 0.8.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.8.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 906d92e8292c..7de8a6be0ec8 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.8.0.tar.gz 57529 BLAKE2B b8068c7781b8b164b9b5d191f8a33a4a89854edb7c78c56d4f1312dd0d051d0b033f21611066303acb7efdf8403d6869458db98e7b1b2a293c779cca2bdcdd36 SHA512 df39fa02d7f4f72334286305bfa9c2db6d5db90bddc47194e3383a99492366796c7ae2e751bcf8af01d14cfa0bac88ea8d9c8678b7891f85aaa1b20e4a9e91cb
+DIST iwdevtools-0.8.1.tar.gz 58058 BLAKE2B b9f17f68bb073ecf2d8a94fc8b97d95f7188e7526dd6a32cf33aa3b01fe82bf25c696cc2be9cbdc0aaa3a8279532e506ab287d3e25da5d5fb55789064d47aec6 SHA512 cb365e7010d620f2a255db0244ee1a38fd5714a17093b2e2a71627155764165853f99a4477b281b92061f7fe184297a222a8c79c2c62beb8e0656761feee859b
diff --git a/app-portage/iwdevtools/iwdevtools-0.8.1.ebuild b/app-portage/iwdevtools/iwdevtools-0.8.1.ebuild
new file mode 100644
index 000000000000..5add38623491
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.8.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ sys-apps/util-linux"
+BDEPEND="
+ sys-apps/help2man
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+
+ if [[ ${REPLACING_VERSIONS} ]] &&
+ ver_test ${REPLACING_VERSIONS} -le 0.7.0; then
+ elog "qa-* bashrcs now use \`eqawarn\` for portage output. If no longer"
+ elog "seeing messages post-emerge, ensure 'qa' is in PORTAGE_ELOG_CLASSES."
+ fi
+}