summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-08-21 23:19:27 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-21 23:19:43 -0400
commitedba145460ac87119d5fe6193e5ce30d19c9b30a (patch)
treeda90334c9ffb479061e6a80ab8e4fed8e0bc1e81 /app-portage/iwdevtools
parentapp-admin/calamares: add missing libcrypt dependency (diff)
downloadgentoo-edba145460ac87119d5fe6193e5ce30d19c9b30a.tar.gz
gentoo-edba145460ac87119d5fe6193e5ce30d19c9b30a.tar.bz2
gentoo-edba145460ac87119d5fe6193e5ce30d19c9b30a.zip
app-portage/iwdevtools: add optfeature on libabigail
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage/iwdevtools')
-rw-r--r--app-portage/iwdevtools/iwdevtools-9999.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/app-portage/iwdevtools/iwdevtools-9999.ebuild b/app-portage/iwdevtools/iwdevtools-9999.ebuild
index 567370192dbf..37791578e223 100644
--- a/app-portage/iwdevtools/iwdevtools-9999.ebuild
+++ b/app-portage/iwdevtools/iwdevtools-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit git-r3 meson
+inherit git-r3 meson optfeature
DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
HOMEPAGE="https://github.com/ionenwks/iwdevtools"
@@ -34,4 +34,6 @@ pkg_postinst() {
elog " ln -s ../../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
elog
fi
+
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
}