summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-07 19:00:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-07 19:01:46 +0200
commit5e730b015d328b82d8b8206efc2489d58812589b (patch)
treecb123c1556264bf55551268f1dc2c62790e86c08 /app-portage/kuroneko
parentwww-client/opera-developer: remove old (diff)
downloadgentoo-5e730b015d328b82d8b8206efc2489d58812589b.tar.gz
gentoo-5e730b015d328b82d8b8206efc2489d58812589b.tar.bz2
gentoo-5e730b015d328b82d8b8206efc2489d58812589b.zip
app-portage/kuroneko: Bump to 0.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/kuroneko')
-rw-r--r--app-portage/kuroneko/Manifest1
-rw-r--r--app-portage/kuroneko/kuroneko-0.1.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-portage/kuroneko/Manifest b/app-portage/kuroneko/Manifest
index 530822018fb4..3366574a4a6c 100644
--- a/app-portage/kuroneko/Manifest
+++ b/app-portage/kuroneko/Manifest
@@ -1 +1,2 @@
DIST kuroneko-0.1.0.tar.gz 8964 BLAKE2B 051539ab6714332b02188854debe655d405093418a3edcf88f58bc54f153c5e9cecf9f9ab165ea32e9dc1d967c43618249b2a6677cb74ea020b05def99479d1b SHA512 b4f9e4cbf932927549ab1411aba15e8ca394919e80a19f7bd04a560764d74c7c884e96133c9aad1be69f9646b1d37713dfb449a1ca09bd74d407101789c213c1
+DIST kuroneko-0.1.1.tar.gz 10223 BLAKE2B aad046291218139662e74c653241bfb36180a0f7fdb4e3571c4d3c8787c41032c48a96d7b02f612e957b2a0eca9fd880daa03c31302d2e92eb6dec5df1b18aab SHA512 c4f29cb5244e659f2615cca706d002c9f20b200b51c964250da8c915d45bcaca03eac2a2dbc19e1d9b6a6374b7458b2c9e0a004e0fa14b1655e8c2c9ce8268a9
diff --git a/app-portage/kuroneko/kuroneko-0.1.1.ebuild b/app-portage/kuroneko/kuroneko-0.1.1.ebuild
new file mode 100644
index 000000000000..9b74e4af13e3
--- /dev/null
+++ b/app-portage/kuroneko/kuroneko-0.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Vulnerability checker using data scraped from Gentoo Bugzilla"
+HOMEPAGE="https://github.com/mgorny/kuroneko/"
+SRC_URI="
+ https://github.com/mgorny/kuroneko/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="scraper"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ scraper? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ test? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest