summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-06 09:08:26 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-06 09:19:32 +0200
commitf82eaff4b7671de0107b7d70372fe1c98150d756 (patch)
treef262275267040c1c2b4fac799cb03982d3da162b /app-portage/kuroneko
parentwww-servers/puma: cleanup (diff)
downloadgentoo-f82eaff4b7671de0107b7d70372fe1c98150d756.tar.gz
gentoo-f82eaff4b7671de0107b7d70372fe1c98150d756.tar.bz2
gentoo-f82eaff4b7671de0107b7d70372fe1c98150d756.zip
app-portage/kuroneko: New vulnerability checker for Gentoo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/kuroneko')
-rw-r--r--app-portage/kuroneko/Manifest1
-rw-r--r--app-portage/kuroneko/kuroneko-0.1.0.ebuild34
-rw-r--r--app-portage/kuroneko/metadata.xml13
3 files changed, 48 insertions, 0 deletions
diff --git a/app-portage/kuroneko/Manifest b/app-portage/kuroneko/Manifest
new file mode 100644
index 000000000000..530822018fb4
--- /dev/null
+++ b/app-portage/kuroneko/Manifest
@@ -0,0 +1 @@
+DIST kuroneko-0.1.0.tar.gz 8964 BLAKE2B 051539ab6714332b02188854debe655d405093418a3edcf88f58bc54f153c5e9cecf9f9ab165ea32e9dc1d967c43618249b2a6677cb74ea020b05def99479d1b SHA512 b4f9e4cbf932927549ab1411aba15e8ca394919e80a19f7bd04a560764d74c7c884e96133c9aad1be69f9646b1d37713dfb449a1ca09bd74d407101789c213c1
diff --git a/app-portage/kuroneko/kuroneko-0.1.0.ebuild b/app-portage/kuroneko/kuroneko-0.1.0.ebuild
new file mode 100644
index 000000000000..0bd9b554e20a
--- /dev/null
+++ b/app-portage/kuroneko/kuroneko-0.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Vulnerability checker using data scraped from Gentoo Bugzilla"
+HOMEPAGE="https://github.com/mgorny/kuroneko/"
+SRC_URI="
+ https://github.com/mgorny/kuroneko/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="scraper"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ scraper? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ test? (
+ dev-python/bracex[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/app-portage/kuroneko/metadata.xml b/app-portage/kuroneko/metadata.xml
new file mode 100644
index 000000000000..b09f3f81a528
--- /dev/null
+++ b/app-portage/kuroneko/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name="scraper">
+ Include the dependencies necessary for Bugzilla scraping.
+ </flag>
+ </use>
+</pkgmetadata>