summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-01 15:08:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-01 15:08:23 +0200
commitf02867d2f8c2351b520c8cd447d07397994be381 (patch)
tree62cea91108edfd20dfc9adfc700a18ed0322aaf1 /app-portage/nattka/nattka-9999.ebuild
parentdev-erlang/p1_oauth2: Re-add test restriction (diff)
downloadgentoo-f02867d2f8c2351b520c8cd447d07397994be381.tar.gz
gentoo-f02867d2f8c2351b520c8cd447d07397994be381.tar.bz2
gentoo-f02867d2f8c2351b520c8cd447d07397994be381.zip
app-portage/nattka: Initial live ebuild for arch testing tool
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/nattka/nattka-9999.ebuild')
-rw-r--r--app-portage/nattka/nattka-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-portage/nattka/nattka-9999.ebuild b/app-portage/nattka/nattka-9999.ebuild
new file mode 100644
index 000000000000..7b4d254d3564
--- /dev/null
+++ b/app-portage/nattka/nattka-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+EGIT_REPO_URI="https://github.com/mgorny/nattka.git"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-util/pkgcheck[${PYTHON_USEDEP}]
+ sys-apps/pkgcore[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( dev-python/vcrpy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest