summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2019-07-06 11:35:00 +0200
committerDaniel Pielmeier <billie@gentoo.org>2019-07-06 11:36:51 +0200
commit0fcc0edeeea51eb0cab9cc79466eaf4f015acce2 (patch)
treeb22ceffd01664c422352d067c48d5bc7f32bcee8 /app-portage/pfl
parentapp-editors/emacs-vcs: Carry over ~riscv keyword from app-editors/emacs. (diff)
downloadgentoo-0fcc0edeeea51eb0cab9cc79466eaf4f015acce2.tar.gz
gentoo-0fcc0edeeea51eb0cab9cc79466eaf4f015acce2.tar.bz2
gentoo-0fcc0edeeea51eb0cab9cc79466eaf4f015acce2.zip
app-portage/pfl: Version bump to pfl-3..1.
This fixes bugs #674120, #679772 and #684346. Signed-off-by: Daniel Pielmeier <billie@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'app-portage/pfl')
-rw-r--r--app-portage/pfl/Manifest1
-rw-r--r--app-portage/pfl/pfl-3.0.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-portage/pfl/Manifest b/app-portage/pfl/Manifest
index 48532ac50b60..97f3f7b0d33e 100644
--- a/app-portage/pfl/Manifest
+++ b/app-portage/pfl/Manifest
@@ -1 +1,2 @@
+DIST pfl-3.0.1.tar.bz2 4635 BLAKE2B 9610c46e3096bc5f2ff212980026b36b99056a9839b179c2618c3c7d508b90ecb21b0fa566eef54e6a24957251934b04b0013af41b88de57e7e1db558831d883 SHA512 f045ca21360f33f87816e72a4564d862275ea1415b3a79e32815aaa20d7548da3f38ca9ee9247db3150adbdd54155b330c4ae6d3bee878db6cd5cf78dada81b5
DIST pfl-3.0.tar.bz2 4332 BLAKE2B 8e1dd17d0017cd972c02a9e8d3610a036447d7b898c6f0a9557ef2c598c0581a09ee7a72ca04860f3695d06d3fe3ee9426a99b1158db71e232ccaff69479d068 SHA512 94f7cc575689f46a0b9ce50c3de7d6a42767766c8c447616c7f3587438a6b3c09e5d00b3b80cd71b0d386ead1e396d49aa266ff408146f85b18e25ebfe887108
diff --git a/app-portage/pfl/pfl-3.0.1.ebuild b/app-portage/pfl/pfl-3.0.1.ebuild
new file mode 100644
index 000000000000..9e577b97b8c4
--- /dev/null
+++ b/app-portage/pfl/pfl-3.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de"
+SRC_URI="https://dev.gentoo.org/~billie/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ net-misc/curl
+ sys-apps/portage[${PYTHON_USEDEP}]
+ >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ keepdir /var/lib/${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+ fi
+ chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+ chmod 775 "${EROOT}/var/lib/${PN}" || die
+}