summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-09-08 13:36:18 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-09-08 13:36:48 +0300
commit4e848233c972e0fbca60dc972dede55b144495e5 (patch)
tree01f3b54bf3bedec7ea759b2da1310ea6372c0f3c /app-portage/pgo/pgo-0.0.3.ebuild
parentdev-perl/Filesys-Df: -r bump for EAPI7 + CFLAGS love (diff)
downloadgentoo-4e848233c972e0fbca60dc972dede55b144495e5.tar.gz
gentoo-4e848233c972e0fbca60dc972dede55b144495e5.tar.bz2
gentoo-4e848233c972e0fbca60dc972dede55b144495e5.zip
app-portage/pgo: Version bump (v0.0.3)
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-portage/pgo/pgo-0.0.3.ebuild')
-rw-r--r--app-portage/pgo/pgo-0.0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-portage/pgo/pgo-0.0.3.ebuild b/app-portage/pgo/pgo-0.0.3.ebuild
new file mode 100644
index 000000000000..e3a6873088bd
--- /dev/null
+++ b/app-portage/pgo/pgo-0.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arzano/pgo"
+else
+ SRC_URI="https://github.com/arzano/pgo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A command line interface for packages.gentoo.org"
+HOMEPAGE="https://github.com/arzano/pgo"
+LICENSE="BSD-2"
+SLOT="0"
+
+src_compile() {
+ env GOBIN="${S}/bin" go build -mod=vendor || die "compile failed"
+}
+
+src_install() {
+ dobin pgo
+}