summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2016-12-04 16:12:44 -0500
committerMike Pagano <mpagano@gentoo.org>2016-12-04 16:12:59 -0500
commit24be101b15698f036058e82542b27c97b1b5bc29 (patch)
tree4c265ab8dccc629d33c8d6e98498c45af3c42c0b /app-portage/portpeek/portpeek-2.1.21.ebuild
parentdev-perl/MongoDB: Bump to version 1.6.0 (diff)
downloadgentoo-24be101b15698f036058e82542b27c97b1b5bc29.tar.gz
gentoo-24be101b15698f036058e82542b27c97b1b5bc29.tar.bz2
gentoo-24be101b15698f036058e82542b27c97b1b5bc29.zip
app-portage/portpeek: Handle unreadable files. Work on bug when parsing package.use files. Bug #601446
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-portage/portpeek/portpeek-2.1.21.ebuild')
-rw-r--r--app-portage/portpeek/portpeek-2.1.21.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-2.1.21.ebuild b/app-portage/portpeek/portpeek-2.1.21.ebuild
new file mode 100644
index 000000000000..bec3ebcbd883
--- /dev/null
+++ b/app-portage/portpeek/portpeek-2.1.21.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.3.2-r1
+ >=sys-apps/portage-2.3.0[${PYTHON_USEDEP}]"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}