summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-08-06 09:32:14 -0400
committerMike Pagano <mpagano@gentoo.org>2018-08-06 09:32:20 -0400
commit77aa0f538094400b6680223af357aefbb376828c (patch)
tree9257bf74f662e19fdf7b213c7779200c4573351f /app-portage/portpeek/portpeek-2.1.27.ebuild
parentapp-emulation/spice: fix build for libressl 2.7+ (diff)
downloadgentoo-77aa0f538094400b6680223af357aefbb376828c.tar.gz
gentoo-77aa0f538094400b6680223af357aefbb376828c.tar.bz2
gentoo-77aa0f538094400b6680223af357aefbb376828c.zip
app-portage/portpeek: Portage API update
Fix portage api call from using deprecated parameters Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'app-portage/portpeek/portpeek-2.1.27.ebuild')
-rw-r--r--app-portage/portpeek/portpeek-2.1.27.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-2.1.27.ebuild b/app-portage/portpeek/portpeek-2.1.27.ebuild
new file mode 100644
index 000000000000..cacbd8405782
--- /dev/null
+++ b/app-portage/portpeek/portpeek-2.1.27.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="http://www.mpagano.com/blog/?page_id=3"
+SRC_URI="http://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.4.0
+ || (
+ >=sys-apps/portage-2.3.19-r1[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}