summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-08-28 16:56:43 -0400
committerMike Pagano <mpagano@gentoo.org>2020-08-28 16:56:43 -0400
commit430157658be8db634927e045a46b40691b69a3c6 (patch)
tree2fe65a76097d7fb554435c7d7ea3c1a01380184b /app-portage/portpeek/portpeek-3.1.4.ebuild
parentdev-perl/DateTime-Locale: Bump to version 1.270.0 (diff)
downloadgentoo-430157658be8db634927e045a46b40691b69a3c6.tar.gz
gentoo-430157658be8db634927e045a46b40691b69a3c6.tar.bz2
gentoo-430157658be8db634927e045a46b40691b69a3c6.zip
app-portage/portpeek: Fix bug in is_any_cpv_file_masked
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'app-portage/portpeek/portpeek-3.1.4.ebuild')
-rw-r--r--app-portage/portpeek/portpeek-3.1.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/portpeek/portpeek-3.1.4.ebuild b/app-portage/portpeek/portpeek-3.1.4.ebuild
new file mode 100644
index 000000000000..9bda36898f42
--- /dev/null
+++ b/app-portage/portpeek/portpeek-3.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit python-r1
+
+DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
+HOMEPAGE="https://www.mpagano.com/blog/?page_id=3"
+SRC_URI="https://www.mpagano.com/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=app-portage/gentoolkit-0.4.8
+ || (
+ >=sys-apps/portage-3.0.0[${PYTHON_USEDEP}]
+ )"
+
+src_install() {
+ python_foreach_impl python_doscript ${PN}
+ doman *.[0-9]
+}