summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-11 19:41:39 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-11 19:44:26 +0100
commit3b433a350e2e26cdcff4609f21659b5205f49fce (patch)
tree2571952af159b29764cf8e7650ba27f952ed736b /app-portage/pycargoebuild/pycargoebuild-0.5.3.ebuild
parentdev-python/regex: Stabilize 2022.10.31 sparc, #885249 (diff)
downloadgentoo-3b433a350e2e26cdcff4609f21659b5205f49fce.tar.gz
gentoo-3b433a350e2e26cdcff4609f21659b5205f49fce.tar.bz2
gentoo-3b433a350e2e26cdcff4609f21659b5205f49fce.zip
app-portage/pycargoebuild: Bump to 0.5.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage/pycargoebuild/pycargoebuild-0.5.3.ebuild')
-rw-r--r--app-portage/pycargoebuild/pycargoebuild-0.5.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/pycargoebuild/pycargoebuild-0.5.3.ebuild b/app-portage/pycargoebuild/pycargoebuild-0.5.3.ebuild
new file mode 100644
index 000000000000..ddee9ac385b4
--- /dev/null
+++ b/app-portage/pycargoebuild/pycargoebuild-0.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A generator for Rust/Cargo ebuilds written in Python"
+HOMEPAGE="
+ https://github.com/projg2/pycargoebuild/
+ https://pypi.org/project/pycargoebuild/
+"
+SRC_URI="
+ https://github.com/projg2/pycargoebuild/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+
+distutils_enable_tests pytest