summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-24 23:53:00 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-25 00:03:28 +0200
commit4c06c94edfcce28396491a81569f4e8ca18ec26d (patch)
tree16c3207c9e5435301e23efbb0796636491ab44a9 /app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild
parentapp-portage/smart-live-rebuild: Bump the live ebuild to EAPI=6 (diff)
downloadgentoo-4c06c94edfcce28396491a81569f4e8ca18ec26d.tar.gz
gentoo-4c06c94edfcce28396491a81569f4e8ca18ec26d.tar.bz2
gentoo-4c06c94edfcce28396491a81569f4e8ca18ec26d.zip
app-portage/smart-live-rebuild: Bump to 1.3.5
Diffstat (limited to 'app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild')
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild
new file mode 100644
index 000000000000..19a3369a8d7a
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+# Tests need to be fixed
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}