summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-31 22:15:53 +0000
committerSam James <sam@gentoo.org>2021-10-31 22:15:59 +0000
commit6db3b67f68767bcfe587f37f8d91195440ba7291 (patch)
tree6f31452dbc096c5f491d46421748fd3df005e486 /app-portage/tatt
parentgames-util/mcrcon: Version bump to 0.7.2, EAPI 8: revert (diff)
downloadgentoo-6db3b67f68767bcfe587f37f8d91195440ba7291.tar.gz
gentoo-6db3b67f68767bcfe587f37f8d91195440ba7291.tar.bz2
gentoo-6db3b67f68767bcfe587f37f8d91195440ba7291.zip
app-portage/tatt: add 0.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage/tatt')
-rw-r--r--app-portage/tatt/Manifest1
-rw-r--r--app-portage/tatt/tatt-0.9.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-portage/tatt/Manifest b/app-portage/tatt/Manifest
index a1301b00ad2f..d090e3ee0ed7 100644
--- a/app-portage/tatt/Manifest
+++ b/app-portage/tatt/Manifest
@@ -1 +1,2 @@
DIST tatt-0.8.tar.gz 22215 BLAKE2B 6c21acb9378045679c4a03badcb7c60638c4007ba19857d7519f68d4d658cd1418e952cf15a64679c6a9b28090856a588e60e9db1abb360d0625a633491deb3d SHA512 31be6573e3d7c9a690e57d64adcbf87983d5dd226afd162c7bfa425847a84705beda530cd5b648ac85cf8cd3907d46ae638bb0ca0d903d8d1968d0ac30703703
+DIST tatt-0.9.tar.gz 22659 BLAKE2B c67da6d71bd46a7a1e73810f6f837cbe18b4fcfdf18da2401ab696e69d05c3ccbdeacaf152999dbf49d39c20e0e9e656e05c294a5eb7128015ee06d25bf95fcb SHA512 4f8d4f6d56ce1389caee8a67d1ae13967692fad90e1bc484ec9ffd9fa057e858c2fc4e6cefa496b33c7565b06e7f71e012a94653de4a501f3b25ec77d07cea92
diff --git a/app-portage/tatt/tatt-0.9.ebuild b/app-portage/tatt/tatt-0.9.ebuild
new file mode 100644
index 000000000000..b68190910f9b
--- /dev/null
+++ b/app-portage/tatt/tatt-0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Arch testing tool"
+HOMEPAGE="https://github.com/gentoo/tatt"
+SRC_URI="https://github.com/gentoo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+templates"
+
+RDEPEND="
+ app-portage/eix
+ app-portage/gentoolkit[${PYTHON_USEDEP}]
+ app-portage/nattka[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-client/pybugz
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use templates; then
+ insinto "/usr/share/${PN}"
+ doins -r templates
+ fi
+ doman tatt.1
+ doman tatt.5
+}