summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-18 15:53:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-18 15:54:21 +0100
commit064cd7cfb2069983d839af2a5dbc524fcac9a7b0 (patch)
treee51c67531aa271b3cd1816af4b44acd448024a08 /app-portage
parentdev-python/pyenchant: Stabilize 3.2.0 sparc, #765295 (diff)
downloadgentoo-064cd7cfb2069983d839af2a5dbc524fcac9a7b0.tar.gz
gentoo-064cd7cfb2069983d839af2a5dbc524fcac9a7b0.tar.bz2
gentoo-064cd7cfb2069983d839af2a5dbc524fcac9a7b0.zip
app-portage/unsymlink-lib: Bump to v20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/unsymlink-lib/Manifest1
-rw-r--r--app-portage/unsymlink-lib/unsymlink-lib-20.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/unsymlink-lib/Manifest b/app-portage/unsymlink-lib/Manifest
index c852133b6567..8963d412ff80 100644
--- a/app-portage/unsymlink-lib/Manifest
+++ b/app-portage/unsymlink-lib/Manifest
@@ -1 +1,2 @@
DIST unsymlink-lib-19.tar.gz 11235 BLAKE2B 955583517c485125722bdc808e1038c038509fad0afe0774f16299f2eb3a6088d7433e11565567bb3c9976a27910fbd9fe92289eaa210062f38eb9e3b15e120b SHA512 98943c887aeb70fc667c2092b985fe0078f127123d271cc45e1abb3e9b6218f1190bd23f140fa9775dca1d473d03113e6cfa8aeca8985cfc31f1cb459c4c620e
+DIST unsymlink-lib-20.tar.gz 11333 BLAKE2B bf5ab4390e52dceb0f86717abc21d752449754b6cb1083b34547997377c24618412d1dfef9736286d5af35632113885c998bddaeb373267280289b93a9ee8f40 SHA512 084d733046499ffa3bbeec6f59e72a8bd8bd9924c6f4cdca5f1bec5a6ef59502ceb19b156783c14d0418dbcd37025da65caaa2ce47665a26cec609e1895b01fb
diff --git a/app-portage/unsymlink-lib/unsymlink-lib-20.ebuild b/app-portage/unsymlink-lib/unsymlink-lib-20.ebuild
new file mode 100644
index 000000000000..46e5fca98af7
--- /dev/null
+++ b/app-portage/unsymlink-lib/unsymlink-lib-20.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit python-single-r1
+
+DESCRIPTION="Convert your system to SYMLINK_LIB=no"
+HOMEPAGE="https://github.com/mgorny/unsymlink-lib"
+SRC_URI="https://github.com/mgorny/unsymlink-lib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# tests are docker-based, you need a running docker daemon and you
+# should expect leftover images
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ sys-apps/portage[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+src_install() {
+ python_doscript unsymlink-lib
+ dodoc README
+}