summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-25 09:49:48 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-25 09:56:33 +0200
commit12402dd25db307d068617471a7bcf76be58ceb71 (patch)
treed4538a217425ea968447c38aaf0a7e49db643cbe /app-portage
parentdev-java/java-sdk-docs: Bump zo 11.0.5 (diff)
downloadgentoo-12402dd25db307d068617471a7bcf76be58ceb71.tar.gz
gentoo-12402dd25db307d068617471a7bcf76be58ceb71.tar.bz2
gentoo-12402dd25db307d068617471a7bcf76be58ceb71.zip
app-portage/gemato: Bump to 14.3
Closes: https://bugs.gentoo.org/698446 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-14.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 2ed7cb7c1404..c43a4d07167c 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,3 +1,4 @@
DIST gemato-14.1-multiprocessing.tar.gz 71707 BLAKE2B d7d22615a65bd598160b23e01a938c20ecadfb1a1332db3842b14bfac69006269efd0f1da6d6bf0f10f3aafb07ebe01af09e64f9612c50b8e98a0bd6aff27651 SHA512 fd4722dd2f632bda4abac59b7e62f531edbdc455be1f1ec94d8bf99194956de15b6cfa4d623713bf3c25e55a6cc6adcdf8039cb7d20a556924bed0ddefd95daf
DIST gemato-14.1.tar.gz 71142 BLAKE2B a7c8f814f9c6875e977aa178d4a49e3454ea8d6e19750786452aa2f34f0904f0ccc0a9a58411a0214a68cecd571320769c6374b265e2aa7f52fbead53ba6b284 SHA512 de57f3b7aa17e650894876bc2423c4fa9809f2de25aa2fb8ef070e943faa182c80f7ea8a519ecdf6edec8098d11f786344ee872b9e98c69bd6739760652baa2e
DIST gemato-14.2.tar.gz 71315 BLAKE2B e94284512bc42d129ef29b686a007dfaf74e8d325a5596f44ddae0e6ce76bf86cf24fa94ea72476fc17eb575a472ee39b02b987c1f97d987eb03ffe6901d472f SHA512 de4e2764bf5778cb5c5fe23c912d9d8c89c4201256305ce5820555fcb5eea4236b8d64ccac9b1a72fc497ec9a4a4e64446835850a8f9be7a8271cddde52eb561
+DIST gemato-14.3.tar.gz 71325 BLAKE2B d42a5182c12bcc0281df47ddb6b933bb332b9b842b2a5c874c3fa4030ab5a8a16759ee289609d428a3fc1338078cd73d234060354513be88c184d5a6bbec545d SHA512 99904b1a38b8a05ff7bf7c265aa463a56ea3aa6c77dd844dc2d154faae5460e3535f4e9799e8863fda256ee6cd374e051ed98193c9b1fc52dc30c9c2655010cd
diff --git a/app-portage/gemato/gemato-14.3.ebuild b/app-portage/gemato/gemato-14.3.ebuild
new file mode 100644
index 000000000000..d58a025ed50f
--- /dev/null
+++ b/app-portage/gemato/gemato-14.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# pysha3 is broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy{,3} )
+PYTHON_REQ_USE='threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+blake2 bzip2 +gpg lzma sha3 test tools"
+RESTRICT="!test? ( test )"
+
+MODULE_RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy) )"
+
+RDEPEND="${MODULE_RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND=">=dev-python/setuptools-34[${PYTHON_USEDEP}]
+ test? ( ${MODULE_RDEPEND} )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}