summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-06 11:26:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-06 11:26:49 +0200
commit2389583a7acad72506afd72a880c168c712b9595 (patch)
tree3a9a7e81d6eadea086c964d0e3c5c1cef8d19977 /app-portage
parentdev-python/PySensors: update EAPI 7 -> 8, pep517, enable py3_{10,11} (diff)
downloadgentoo-2389583a7acad72506afd72a880c168c712b9595.tar.gz
gentoo-2389583a7acad72506afd72a880c168c712b9595.tar.bz2
gentoo-2389583a7acad72506afd72a880c168c712b9595.zip
app-portage/kuroo: drop 1.2.1-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/kuroo/Manifest1
-rw-r--r--app-portage/kuroo/files/kuroo-1.2.1-cmake.patch108
-rw-r--r--app-portage/kuroo/kuroo-1.2.1-r1.ebuild50
3 files changed, 0 insertions, 159 deletions
diff --git a/app-portage/kuroo/Manifest b/app-portage/kuroo/Manifest
index 441e9a051b30..c0b12acacf38 100644
--- a/app-portage/kuroo/Manifest
+++ b/app-portage/kuroo/Manifest
@@ -1,2 +1 @@
-DIST kuroo-1.2.1.tar.xz 247540 BLAKE2B 69c8a85cd58347b835039f4bc6929abb71baf517ee1de8b10779d4ba08b997bd46a8e0a5b1c55ea2847d80ab58ed336e524cf53cf707416a6182a0dcbd84abc9 SHA512 3815fcdb27c234669accd3abf0f6f252194d680bc1c18f13e66c428cfcef50685019b19ca8fe20fec1b633e6ed224620cf67eea8a29f593b33760d19657d2d24
DIST kuroo-1.2.2.tar.xz 250284 BLAKE2B 57bb80fde83e4506b0e8e9230a9e619ec887327779e1d9700e51bd534fa3d14ab51d3d80aad1def1a67cc14fd446f84f1ea551919578bf7f92cbb5dc4368e172 SHA512 6120508d77fe2b6787aa62994327882bd7abd0a08bfce0905920ab17b7837aabfa271c572377fe16131dd9770e5fd45c82409c6aeae5f27f8c0eb33d4e0cdb4c
diff --git a/app-portage/kuroo/files/kuroo-1.2.1-cmake.patch b/app-portage/kuroo/files/kuroo-1.2.1-cmake.patch
deleted file mode 100644
index a84a503f7d7d..000000000000
--- a/app-portage/kuroo/files/kuroo-1.2.1-cmake.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-Drop bogus dependencies, add implicit.
-
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -11,25 +11,32 @@
- include(ECMInstallIcons)
- include(ECMAddTests)
-
--find_package(Qt5Widgets REQUIRED)
-+# Works without this explicit declaration but it ought to be here for correctness
-+find_package( SQLite3 REQUIRED )
-
--find_package( KF5 ${KF5_MIN_VERSION} REQUIRED
-- Auth
-- Config
-- ConfigWidgets
-- CoreAddons
-- I18n
-- IconThemes
-- ItemModels
-- ItemViews
-+# These are actually all deps of other things
-+find_package( Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS
-+ Core
-+ Gui
-+ Widgets
-+)
-+
-+find_package( KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
-+ # These are all required directly and not provided by any dependencies. It "compiles and works" on the development system with just these
- KIO
- Notifications
- ThreadWeaver
- TextWidgets
-- Su
-- WidgetsAddons
-- WindowSystem
-- XmlGui
-+ # Required in link step
-+ XmlGui # MainWindow is XmlGuiWindow
-+ ItemViews # TreeWidgetSearchLine
-+ # These seem to be provided by deps, but should be direct deps too
-+ ConfigWidgets
-+ I18n # i18n(QStr)
-+ Config # Config dialogs
-+ Auth # KAuthExecuteJob &c.
-+ CoreAddons # AboutData? Job Process User?
-+ WidgetsAddons # Font(Chooser|Requester)? PageWidget? MessageBox ...
- )
-
- #
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -102,25 +102,37 @@
- kde_enable_exceptions()
-
- target_link_libraries( kuroo
-+ # These are all used directly and not provided by any other dependency. It "compiles and works" on the development system with just these
-+ KF5::KIOCore
-+ KF5::Notifications
-+ KF5::ThreadWeaver
-+ KF5::TextWidgets
-+ KF5::XmlGui
-+ sqlite3 # TODO: use some sort of ORM maybe find_package?
-+ KF5::ItemViews
-+ # Builds without these specified, but they should be necessary
- Qt5::Core
-+ Qt5::Gui
-+ Qt5::Widgets
- KF5::Auth
-+ KF5::AuthCore
- KF5::ConfigCore
- KF5::ConfigGui
-+ KF5::ConfigWidgets
- KF5::CoreAddons
- KF5::I18n
-- KF5::ItemViews
-- KF5::KIOCore
-- KF5::Notifications
-- KF5::ThreadWeaver
-- KF5::TextWidgets
- KF5::WidgetsAddons
-- KF5::WindowSystem
-- KF5::XmlGui
-- sqlite3
- )
-
- add_executable( kuroo_helper auth/kuroohelper.cpp )
--target_link_libraries( kuroo_helper Qt5::Core KF5::KIOCore KF5::Auth KF5::CoreAddons )
-+target_link_libraries( kuroo_helper
-+ # These are all used directly and not provided by any other dependency. It "compiles and works" on the development system with just these
-+ KF5::KIOCore
-+ KF5::Auth
-+ # Builds without explicit declaration, but these make sense
-+ Qt5::Core
-+ KF5::CoreAddons # KProcess
-+)
- install( TARGETS kuroo_helper DESTINATION ${KAUTH_HELPER_INSTALL_DIR} )
- kauth_install_helper_files( kuroo_helper org.gentoo.portage.kuroo root )
- kauth_install_actions( org.gentoo.portage.kuroo auth/org.gentoo.portage.kuroo.actions )
-@@ -139,6 +151,6 @@
- ########### install ###############
- install( TARGETS kuroo ${INSTALL_TARGETS_DEFAULT_ARGS} )
- #install( FILES DESTINATION ${DATA_INSTALL_DIR}/autostart )
--install( FILES config/kurooconfig.kcfg DESTINATION ${KCFG_INSTALL_DIR} )
-+install( FILES config/kurooconfig.kcfg DESTINATION ${KDE_INSTALL_KCFGDIR} )
- install( FILES kurooui.rc DESTINATION ${KXMLGUI_INSTALL_DIR}/kuroo )
- install( FILES kuroo.desktop DESTINATION ${XDG_APPS_INSTALL_DIR}/System )
diff --git a/app-portage/kuroo/kuroo-1.2.1-r1.ebuild b/app-portage/kuroo/kuroo-1.2.1-r1.ebuild
deleted file mode 100644
index 9beef337fe4c..000000000000
--- a/app-portage/kuroo/kuroo-1.2.1-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-KFMIN=5.85.0
-inherit ecm
-
-DESCRIPTION="Graphical Portage frontend based on KDE Frameworks"
-HOMEPAGE="https://sourceforge.net/projects/kuroo/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="
- dev-db/sqlite:3
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- >=kde-frameworks/kauth-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/kitemviews-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- >=kde-frameworks/threadweaver-${KFMIN}:5
-"
-RDEPEND="${DEPEND}
- app-portage/gentoolkit
- kde-apps/kompare:5
-"
-BDEPEND=">=kde-frameworks/extra-cmake-modules-${KFMIN}:5"
-
-PATCHES=( "${FILESDIR}/${P}-cmake.patch" ) # bug 811693
-
-pkg_postinst() {
- if ! has_version app-admin/logrotate ; then
- elog "Installing app-admin/logrotate is recommended to keep"
- elog "portage's summary.log size reasonable to view in the history page."
- fi
-
- ecm_pkg_postinst
-}