summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2021-10-07 22:19:25 +0200
committerDaniel Pielmeier <billie@gentoo.org>2021-10-07 22:19:25 +0200
commit2d3655737198098d5c5de88b5da7643ec3e4fc61 (patch)
treefbaa996ff07bfd6fd2c9644c58d1c5505e2841c7 /app-portage
parentwww-servers/apache: Stabilize 2.4.51 arm64, #816870 (diff)
downloadgentoo-2d3655737198098d5c5de88b5da7643ec3e4fc61.tar.gz
gentoo-2d3655737198098d5c5de88b5da7643ec3e4fc61.tar.bz2
gentoo-2d3655737198098d5c5de88b5da7643ec3e4fc61.zip
app-portage/pfl: Version bump.
Closes: https://bugs.gentoo.org/812788 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/Manifest1
-rw-r--r--app-portage/pfl/pfl-3.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-portage/pfl/Manifest b/app-portage/pfl/Manifest
index 0e1adeb7edf0..ca6d4c381cd5 100644
--- a/app-portage/pfl/Manifest
+++ b/app-portage/pfl/Manifest
@@ -1 +1,2 @@
DIST pfl-3.1.tar.gz 5521 BLAKE2B fdc6e82c5d61d694a188c479b0566aafc507bcc2bbd1f176cd2771586b13de86a43a5d2e156beb4c9b5d10cd718046a05fce099894430c8f3d04c0922078e988 SHA512 b2bf79445a5b15caf339106f376d64accf5aad2c60038ba88180d64ce49e23dc3015efa2fcbeec886ba591cada053dfdc96873bda71b092be4622608062b6dcc
+DIST pfl-3.2.tar.gz 5373 BLAKE2B 3fcb771a6d67ec7198b83eeeb161d7caea7ccbc3933ff3ef7a48b106e9c86c331f2ac1a4c589135a4f57f40bfcd668f075f17865ff58feb027cd02d90b52bc2a SHA512 e424b5a5c6dbb848057fe357ae98196f2c238351dfe7fd19a9b7f423c245b1372ec270c6b8d2e8265a05a442d7afc2c5feef6dbe5eed5e240e78c88a6748d1d5
diff --git a/app-portage/pfl/pfl-3.2.ebuild b/app-portage/pfl/pfl-3.2.ebuild
new file mode 100644
index 000000000000..e68f6bf29bbc
--- /dev/null
+++ b/app-portage/pfl/pfl-3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de https://github.com/portagefilelist/client"
+SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="
+ ${DEPEND}
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+ network-cron? ( sys-apps/util-linux[caps] )
+"
+
+S="${WORKDIR}/client-${PV}"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ systemd_dounit systemd/pfl.{service,timer}
+
+ keepdir /var/lib/${PN}
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+ fi
+ chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+ chmod 775 "${EROOT}/var/lib/${PN}" || die
+}