summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-01-04 11:42:02 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2020-01-04 11:42:14 +0000
commit4ff644dd08166b9a00b23752e48b81a8c60888b1 (patch)
tree6f436f5258e2af945efaed55afa93f03756ef24f /app-portage
parentdev-cpp/yaml-cpp: Version bump 0.6.3 (diff)
downloadgentoo-4ff644dd08166b9a00b23752e48b81a8c60888b1.tar.gz
gentoo-4ff644dd08166b9a00b23752e48b81a8c60888b1.tar.bz2
gentoo-4ff644dd08166b9a00b23752e48b81a8c60888b1.zip
app-portage/hackport: bump up to 0.6.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/hackport/Manifest1
-rw-r--r--app-portage/hackport/hackport-0.6.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-portage/hackport/Manifest b/app-portage/hackport/Manifest
index 91dea67d8f0b..7e4b93c5d341 100644
--- a/app-portage/hackport/Manifest
+++ b/app-portage/hackport/Manifest
@@ -4,3 +4,4 @@ DIST hackport-0.5.3.tar.gz 1390724 BLAKE2B 666a1bbb4f5eb4abf6a5546867bbfdaf2280b
DIST hackport-0.5.4.tar.gz 1390924 BLAKE2B 2fcc4ece84b813e130d860048328b7c4b704f1a37cffe15f26f24f8a9db8e7a267f083b1f8469f1d3e9753c07ad17dbbc209a2a8095770a7610fe73baf9965c1 SHA512 49593066608bf8d57678d1725c51da4f1f6213a06b1c5645d97e4a711704adc9a40c66ad4fd6a624572fc7491943874b5b48381bc02545a0e9b6d7a5619be073
DIST hackport-0.5.5.tar.gz 1618493 BLAKE2B 939f0ef89c7bbc4117d6222e8c8d813883a02d1277466477f3ff1910ebaba418969ff4e8c170a6dae8888394254790aeb69ecc69b36e01c9f341663938aa39b5 SHA512 b91fe72884ccc3a6acb79115ba8f8418250e13f102a07542e3d06db3880b572c73d2d4b5c05622eee83af3715f3a854d2cf7142ebb92627d8b332db4152d817d
DIST hackport-0.5.6.tar.gz 1639896 BLAKE2B 2c5892b3206b4cbb10f8dcbce1d043446b7b804ae0b5d1e59c49c733c80194e79c9091cfc933cbc7e7a592c0747ee034d56969d4261ad0a6a585259d5e8b4f76 SHA512 5dc20f11392757224a6cf79d525792e14aba64ffb44c9dd9b4f0df4acd9c00127d85f2b1f23cf2063f80895dbcc90ccc745e8f9aba3ef82f7ae8364db155fe4f
+DIST hackport-0.6.2.tar.gz 1625948 BLAKE2B 9dbb7695d3ca806cfef342697717fa232be2156bcb76c87413907460a9cea2f8cdd517dce453ae7846a00df53ab46058c8f42bd36bc33580cb32452b82c77816 SHA512 99207c4903ee5f3fdcc648edcc3a39ed06f0629a1d5bda577fc2c443c544bfd746154bc5e9de044810c148b1a38028ec0fdf908513b4252c05bb6c9c6eb9aa92
diff --git a/app-portage/hackport/hackport-0.6.2.ebuild b/app-portage/hackport/hackport-0.6.2.ebuild
new file mode 100644
index 000000000000..ec10c7ce40f1
--- /dev/null
+++ b/app-portage/hackport/hackport-0.6.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage and Portage integration tool"
+HOMEPAGE="http://hackage.haskell.org/package/hackport"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # tests are broken: need path to ebuild tree
+
+RDEPEND="
+ app-portage/repoman
+ dev-haskell/async:=
+ dev-haskell/base16-bytestring:=
+ dev-haskell/base64-bytestring:=
+ dev-haskell/cryptohash:=
+ dev-haskell/ed25519:=
+ dev-haskell/extensible-exceptions:=
+ dev-haskell/hashable:=
+ >=dev-haskell/http-4000.0.3:=
+ dev-haskell/missingh:=
+ dev-haskell/mtl:=
+ >=dev-haskell/network-2.6:=
+ >=dev-haskell/network-uri-2.6:=
+ dev-haskell/old-locale:=
+ dev-haskell/old-time:=
+ dev-haskell/parsec:=
+ dev-haskell/random:=
+ dev-haskell/regex-compat:=
+ dev-haskell/split:=
+ dev-haskell/stm:=
+ >=dev-haskell/tar-0.5:=
+ >=dev-haskell/xml-1.3.7:=
+ dev-haskell/zlib:=
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/hunit )
+"
+src_install() {
+ haskell-cabal_src_install
+ doman man/hackport.1
+}