summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-08 15:37:20 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-08 15:37:20 +0200
commit55f36c0e40230388df64eb6e44328dcecdae24ad (patch)
tree48eca30c9c6faeb1d12aecf374f7ca6712aaeef9 /app-portage
parentdev-python/pypax: enable py3.11 (diff)
downloadgentoo-55f36c0e40230388df64eb6e44328dcecdae24ad.tar.gz
gentoo-55f36c0e40230388df64eb6e44328dcecdae24ad.tar.bz2
gentoo-55f36c0e40230388df64eb6e44328dcecdae24ad.zip
app-portage/gverify: EAPI 8, py3.11
Closes: https://bugs.gentoo.org/896442 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gverify/gverify-2.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/app-portage/gverify/gverify-2.ebuild b/app-portage/gverify/gverify-2.ebuild
index c0105de01bb5..5ae4eab359ac 100644
--- a/app-portage/gverify/gverify-2.ebuild
+++ b/app-portage/gverify/gverify-2.ebuild
@@ -1,25 +1,33 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_COMPAT=( python3_{9..10} )
inherit python-single-r1
DESCRIPTION="gentoo.git signature verification tool"
-HOMEPAGE="https://github.com/projg2/gverify"
-SRC_URI="https://github.com/projg2/gverify/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/projg2/gverify/"
+SRC_URI="
+ https://github.com/projg2/gverify/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
app-crypt/gnupg
sec-keys/openpgp-keys-gentoo-auth
- dev-vcs/git"
-DEPEND="${PYTHON_DEPS}"
+ dev-vcs/git
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
src_compile() {
emake PREFIX="${EPREFIX}"/usr