summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-29 07:54:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-29 09:00:17 +0200
commit57368a709e124ca57fa735fba6540449c9a70623 (patch)
tree9d691442571bc7616d6ffb7612b891fa26db96b7 /app-portage
parentdev-python/dask: Bump to 2023.4.1 (diff)
downloadgentoo-57368a709e124ca57fa735fba6540449c9a70623.tar.gz
gentoo-57368a709e124ca57fa735fba6540449c9a70623.tar.bz2
gentoo-57368a709e124ca57fa735fba6540449c9a70623.zip
app-portage/gemato: Bump to 20.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-20.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index de5a45150d99..3cabee2731cd 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-20.1.gh.tar.gz 86394 BLAKE2B c8f8f855a5b56dbf06eef0c99e33d4ad04c8151fa121d152c9f918059436e21dafc98d3931465cc27f4c489c8e4f576abe73efd810df09896e4fe91e9aa21814 SHA512 d4395f95b5807473511cfc9631dc9db3cff610d3f3b12c8360ee452b964ea6610c76f7f1687b6b21f44fde93d6921731b1791ff51d908d3e7fd154beef6ac596
+DIST gemato-20.2.tar.gz 88522 BLAKE2B c001f54cbc1a978a861e93e663fbd943b7b3504944a53aa1a88a84a3a8c269e9cb10dd0738cf103e33abf23fb7e6b116cddf85d318ddc01372e85e4fbf93eade SHA512 d0095efbf040788c0f6f0ae11ff55666cafc030597118b20c392bdcd63e2bc2cc504a279f4219fe91e12408f22896486bd094185c5506e92600291620af2c0a8
diff --git a/app-portage/gemato/gemato-20.2.ebuild b/app-portage/gemato/gemato-20.2.ebuild
new file mode 100644
index 000000000000..7d79f8e034a1
--- /dev/null
+++ b/app-portage/gemato/gemato-20.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg pretty-log tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}