summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-16 15:09:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-16 15:17:27 +0200
commit58887498e92abdaa07eb39aeb4e4d4bd2ee3e425 (patch)
treeb277e3fd1de63a94f1d8bf1fbc838031d43614fe /app-portage
parentdev-util/packer: bump version to 1.6.1 (diff)
downloadgentoo-58887498e92abdaa07eb39aeb4e4d4bd2ee3e425.tar.gz
gentoo-58887498e92abdaa07eb39aeb4e4d4bd2ee3e425.tar.bz2
gentoo-58887498e92abdaa07eb39aeb4e4d4bd2ee3e425.zip
app-portage/gentoopm: Bump to 0.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoopm/Manifest1
-rw-r--r--app-portage/gentoopm/gentoopm-0.3.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/gentoopm/Manifest b/app-portage/gentoopm/Manifest
index 64acc2798bbe..1a8ecab591d8 100644
--- a/app-portage/gentoopm/Manifest
+++ b/app-portage/gentoopm/Manifest
@@ -1 +1,2 @@
DIST gentoopm-0.3.1.tar.gz 37897 BLAKE2B dd5499787bcc5c46ae3b559f3af4a5af5b4ca81a312e926149c587cac0391c51dbe61ac42d2bc19eb83cedc168486e9c30ddd6fbf4ae10ffd9719aefa2f54cd3 SHA512 e1a3a7929ae83d813dd0b03f0548f033e8e51b766aaddb653027398fb618819de6237e2ba1c0542defc9d62e71e8495aa10152cbc47a4e521f7cbaeda3ea4354
+DIST gentoopm-0.3.2.tar.gz 38430 BLAKE2B df8536b384cdad754894d65b605ab688cedc09430bcc3cd0821ed1ae9a93d0cb5e7b076715edf6eaed6bbf5ffc9088fb14d8bd5a04c3809c38ce05c6ed106bb9 SHA512 d99034af2efada3647117c75d5602bc5878a8f0e79d1c6b502fdb0fa272f7b9148afbbe4d379a2957a7db6694b4001158e2dfce8e3a4f97692e20a803417f571
diff --git a/app-portage/gentoopm/gentoopm-0.3.2.ebuild b/app-portage/gentoopm/gentoopm-0.3.2.ebuild
new file mode 100644
index 000000000000..5582cd45b7ef
--- /dev/null
+++ b/app-portage/gentoopm/gentoopm-0.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A common interface to Gentoo package managers"
+HOMEPAGE="https://github.com/mgorny/gentoopm/"
+SRC_URI="https://github.com/mgorny/gentoopm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+RDEPEND="
+ || (
+ >=sys-apps/pkgcore-0.9.4[${PYTHON_USEDEP}]
+ >=sys-apps/portage-2.1.10.3[${PYTHON_USEDEP}] )"
+PDEPEND="app-eselect/eselect-package-manager"
+
+python_test() {
+ esetup.py test
+}