summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-19 20:53:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-19 20:53:59 +0100
commit5bae1539a14da3f8678f9c9b3040c15849bc002b (patch)
tree1f093a149ecc9ee97e50855fc8b624a6d8d35c04 /app-portage
parentsys-fs/vhba: add missing linux-mod_pkg_postinst to ebuild (diff)
downloadgentoo-5bae1539a14da3f8678f9c9b3040c15849bc002b.tar.gz
gentoo-5bae1539a14da3f8678f9c9b3040c15849bc002b.tar.bz2
gentoo-5bae1539a14da3f8678f9c9b3040c15849bc002b.zip
app-portage/smart-live-rebuild: Bump to 1.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/Manifest1
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.4.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/Manifest b/app-portage/smart-live-rebuild/Manifest
index 3725a27ab008..698e14debec3 100644
--- a/app-portage/smart-live-rebuild/Manifest
+++ b/app-portage/smart-live-rebuild/Manifest
@@ -1 +1,2 @@
DIST smart-live-rebuild-1.4.0.tar.gz 17630 BLAKE2B 84faabbe702dc05dbd895961dba83b8b8968bafcc5e35bd1b7dc8644f98a904651168aaee081ecb0c101761def2f5d49046116179156e75f6b335a79595d82e6 SHA512 add82ac413c698a430afbb48a7d4c7d0dae26b9d37f01dcbe7f71ee2e2fbc1686ff63c6ea9ae1c24dbc3662d27247bec2ccc002841bd42c4c11729873a49617f
+DIST smart-live-rebuild-1.4.1.tar.gz 17759 BLAKE2B c45825fffc3e30e3fdb02d16c8998bafe492462bdbff9fd5d4c67ca297ecb4da6828a9c0b6c98262f92a518482b0dc99d3022a769e22bdeaf4270ee34b1a5d5a SHA512 401222564b9920a5c8b08c0bad393f18ffbb2d3eabea6aa1a0c04bc728ffd362ec7fccb8884023ff183398085c0017d2f59d86b293ed91cc3a2bcb185aef239e
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.1.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.1.ebuild
new file mode 100644
index 000000000000..c5c249a91a45
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/projg2/smart-live-rebuild/"
+SRC_URI="https://github.com/projg2/smart-live-rebuild/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}