summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-09 13:06:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-09 16:44:39 +0200
commit5ed63ef841f881ef52e7b6997fd07e243131fd04 (patch)
treeb6d3d2c672ac066a410a076eaf205a3f5aa1a3a3 /app-portage
parentsys-devel/clang: Enable prebuilt manpages for 12.0.1 (diff)
downloadgentoo-5ed63ef841f881ef52e7b6997fd07e243131fd04.tar.gz
gentoo-5ed63ef841f881ef52e7b6997fd07e243131fd04.tar.bz2
gentoo-5ed63ef841f881ef52e7b6997fd07e243131fd04.zip
app-portage/nattka: Bump to 0.2.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/nattka/Manifest1
-rw-r--r--app-portage/nattka/nattka-0.2.14.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-portage/nattka/Manifest b/app-portage/nattka/Manifest
index 85854d839cb7..4508377e3959 100644
--- a/app-portage/nattka/Manifest
+++ b/app-portage/nattka/Manifest
@@ -1 +1,2 @@
DIST nattka-0.2.13.tar.gz 93917 BLAKE2B 48e5245234d0ef0fd47353bac0d971d6187f59d94c0fb58f4cce160ee28f847a8fb32f8399af3148daaac299b32b590899de716dee1ee9cf107b1efe2451189f SHA512 0d3428cb3b5dee3fcdc29b9d22b5c05d626d26060fcd5518f789493fc68e51762edf9162a9b5b19c6c08fb9cb9c0e350faa41d96c53bd924b50475176140ccdb
+DIST nattka-0.2.14.tar.gz 93925 BLAKE2B 2fa31e8b4ea8aa74d2af52e5a410288715495997c328c5415a65200a077a385eacb3050e593c778194f2e519fd28d2273679d822e0be55b815e19ff38882dfe3 SHA512 28e24576606813d56c8e37cdd203960a67394893b819d846595a03fd222f6ed2fd319bc5d650f229bf7a8979d3823f28de82a87e3bb76fdaf49e9e02dbf62ac5
diff --git a/app-portage/nattka/nattka-0.2.14.ebuild b/app-portage/nattka/nattka-0.2.14.ebuild
new file mode 100644
index 000000000000..75261fa77b65
--- /dev/null
+++ b/app-portage/nattka/nattka-0.2.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A New Arch Tester Toolkit -- open-source stable-bot replacement"
+HOMEPAGE="https://github.com/mgorny/nattka/"
+SRC_URI="https://github.com/mgorny/nattka/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="depgraph-order"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-util/pkgcheck[${PYTHON_USEDEP}]
+ dev-vcs/git
+ sys-apps/pkgcore[${PYTHON_USEDEP}]
+ depgraph-order? (
+ dev-python/networkx[${PYTHON_USEDEP}]
+ )"
+BDEPEND="
+ test? (
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest