summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-15 13:16:30 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-15 13:16:30 +0100
commit650cceaeb63d15bd38993317e34c8441f39ecd16 (patch)
treecee7dbb735c65dca049677ea5dffeb7dbe8e6dce /app-portage
parentwww-apps/davical: rdepend on <dev-lang/php-8 (diff)
downloadgentoo-650cceaeb63d15bd38993317e34c8441f39ecd16.tar.gz
gentoo-650cceaeb63d15bd38993317e34c8441f39ecd16.tar.bz2
gentoo-650cceaeb63d15bd38993317e34c8441f39ecd16.zip
app-portage/smart-live-rebuild: Bump to 1.3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/smart-live-rebuild/Manifest1
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-1.3.7.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/Manifest b/app-portage/smart-live-rebuild/Manifest
index c31b69cdf700..22fddcd3a8a3 100644
--- a/app-portage/smart-live-rebuild/Manifest
+++ b/app-portage/smart-live-rebuild/Manifest
@@ -1 +1,2 @@
DIST smart-live-rebuild-1.3.6.tar.gz 17194 BLAKE2B a1c4f07e66ce3328ae70f88d086c33875bed68aea645a180e68fbd997051c6d398c1133d8e9c72378741fe41c519e941e76dc25d9c3f9c61c36531fe6fbe8e79 SHA512 f9fe57269654d69c3b21d0b6e378dfa3d2c00e67dae44278b2b81d631e4645346ecaeb5c9f43b77d39312b97edee247ba8b05303be903d6a3573bc226159c40f
+DIST smart-live-rebuild-1.3.7.tar.gz 17283 BLAKE2B 9de30e07b7c950c7e0e3d7f20a364ef65028fe425a017cf46de73a4aaa2c82f13359bc8e2d3269ed50b201b95c41af16c6f233576c1176f8c9b6394227bc8e14 SHA512 47111fa0e4ef9630a60b262566166822ac3245338c9cabc9e5959922e6f60cac70087025321fc9946ef7527b02ce7eb25d74e22d045f9e875c82d6f7877feb4b
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.7.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.7.ebuild
new file mode 100644
index 000000000000..ccc36895bd2e
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-1.3.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI="https://github.com/mgorny/smart-live-rebuild/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+# Tests need to be fixed
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}