summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2018-04-23 20:51:29 +0200
committerDaniel Pielmeier <billie@gentoo.org>2018-04-23 20:51:29 +0200
commit8ce3c90779209d99f9a626144e2db7f53329087f (patch)
treeb64ff5b9bf78e28014c750a5cab148bcb17941ae /app-portage
parentvirtual/perl-*: -r1 bump all virtuals with new RDEPEND entries (diff)
downloadgentoo-8ce3c90779209d99f9a626144e2db7f53329087f.tar.gz
gentoo-8ce3c90779209d99f9a626144e2db7f53329087f.tar.bz2
gentoo-8ce3c90779209d99f9a626144e2db7f53329087f.zip
app-portage/pfl: Version bump.
Fixes bugs #508338, #626116 and #638818. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/pfl/Manifest1
-rw-r--r--app-portage/pfl/pfl-3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-portage/pfl/Manifest b/app-portage/pfl/Manifest
index 89ea67baa3e9..4189a02bf65f 100644
--- a/app-portage/pfl/Manifest
+++ b/app-portage/pfl/Manifest
@@ -1 +1,2 @@
DIST pfl-2.4.tar.bz2 6274 BLAKE2B 7cf72dc4b9182b3ea43fb1661330debeb79afdaaab8a519dc2f8f0a048f5f7e66ee2466a44b4683f36eebae248f6df407d0d0fc3914f3a8eb427bc2af0692bb6 SHA512 a33712bc38d6e02474856dc3a9eac0d39be032a9554f2510815602e94648cd6bf499111a3354568788ddcc0a653a2ac54fac56b0af03fb1cf822ec44ffcb1d72
+DIST pfl-3.0.tar.bz2 4332 BLAKE2B 8e1dd17d0017cd972c02a9e8d3610a036447d7b898c6f0a9557ef2c598c0581a09ee7a72ca04860f3695d06d3fe3ee9426a99b1158db71e232ccaff69479d068 SHA512 94f7cc575689f46a0b9ce50c3de7d6a42767766c8c447616c7f3587438a6b3c09e5d00b3b80cd71b0d386ead1e396d49aa266ff408146f85b18e25ebfe887108
diff --git a/app-portage/pfl/pfl-3.0.ebuild b/app-portage/pfl/pfl-3.0.ebuild
new file mode 100644
index 000000000000..ea1a286fa5d2
--- /dev/null
+++ b/app-portage/pfl/pfl-3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_5 )
+PYTHON_REQ_USE="xml"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de"
+SRC_URI="http://files.portagefilelist.de/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ net-misc/curl
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ keepdir /var/lib/${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT%/}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT%/}/var/lib/${PN}/pfl.info" || die
+ chown -R 0:portage "${EROOT%/}/var/lib/${PN}" || die
+ chmod 775 "${EROOT%/}/var/lib/${PN}" || die
+ fi
+}