summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-22 04:51:00 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-22 04:53:03 -0400
commit9f3e0370b30e6c8476b2357eef0b2142cef39ad5 (patch)
treec6bfb55bf54422daea31af8faf89ea3543cbb270 /app-portage
parentmedia-sound/gnump3d: Stabilize 3.0-r5 x86, #914509 (diff)
downloadgentoo-9f3e0370b30e6c8476b2357eef0b2142cef39ad5.tar.gz
gentoo-9f3e0370b30e6c8476b2357eef0b2142cef39ad5.tar.bz2
gentoo-9f3e0370b30e6c8476b2357eef0b2142cef39ad5.zip
app-portage/iwdevtools: add 0.12.8
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.8.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index 9f2359b05e9f..50ea67ba3a89 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.12.7.tar.gz 90988 BLAKE2B c02a8e44ea992f701f27f2d95c4e97a84806b5bf920ccc6097b3c6917162e9a22c5a5d020b43f8ca9ca99d43ec0ce2b2bfcd0c4f0f98eb27e8003346fb9ab70a SHA512 84cd91f6dcb5e080f4ab53f9eaef85d3093f9ce5110066b92e82f7ca1132612e70e8e6cd70a66b2452746a8879cd07bb60c1948c9ebfe9cc8c8c359ea19cc2b1
+DIST iwdevtools-0.12.8.tar.gz 91178 BLAKE2B d131ab44587df0e4c0b8a697298373517ca4d33265aba00c9dd832c9576d8b08c359e20a129b1a5d9aa01fcaaa3a33d410b5c6e521032d1d90bce781483f8c74 SHA512 0236a4cb6dae4c97296525df940000c6c30fd05f85848a7828cfa610ba68dcd09d5d0bf9b76a0444fa172f47ac1d739aa332e494deb4fccbfd6460e779605186
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.8.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.8.ebuild
new file mode 100644
index 000000000000..e4322dc0e41d
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools/"
+SRC_URI="
+ https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1:0[readline]
+ dev-libs/libxml2:2
+ sys-apps/coreutils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )
+"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}