summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-21 15:07:26 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-21 15:10:50 +0100
commita46018e1791946e438c3e7cd36e2ccfdc514055e (patch)
treeb988d2bc969384e4cdfb222680ddf3dec57d25bb /app-portage
parentdev-python/pypax: Set DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-a46018e1791946e438c3e7cd36e2ccfdc514055e.tar.gz
gentoo-a46018e1791946e438c3e7cd36e2ccfdc514055e.tar.bz2
gentoo-a46018e1791946e438c3e7cd36e2ccfdc514055e.zip
app-portage/gemato: Set DISTUTILS_USE_SETUPTOOLS, update tests
Closes: https://bugs.gentoo.org/709892 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/gemato-14.3.ebuild16
-rw-r--r--app-portage/gemato/gemato-9999.ebuild13
2 files changed, 9 insertions, 20 deletions
diff --git a/app-portage/gemato/gemato-14.3.ebuild b/app-portage/gemato/gemato-14.3.ebuild
index 1c2e6cc874a7..7903d882e703 100644
--- a/app-portage/gemato/gemato-14.3.ebuild
+++ b/app-portage/gemato/gemato-14.3.ebuild
@@ -3,8 +3,10 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
PYTHON_REQ_USE='threads(+)'
+
inherit distutils-r1
DESCRIPTION="Stand-alone Manifest generation & verification tool"
@@ -14,24 +16,16 @@ SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-IUSE="+blake2 bzip2 +gpg lzma sha3 test tools"
-RESTRICT="!test? ( test )"
+IUSE="+blake2 bzip2 +gpg lzma sha3 tools"
-MODULE_RDEPEND="
+RDEPEND="
blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )
bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
gpg? ( app-crypt/gnupg )
lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy) )"
-RDEPEND="${MODULE_RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND=">=dev-python/setuptools-34[${PYTHON_USEDEP}]
- test? ( ${MODULE_RDEPEND} )"
-
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py
python_install_all() {
distutils-r1_python_install_all
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index 840a8c6afc7b..a52943c5d571 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -3,8 +3,10 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} pypy3 )
PYTHON_REQ_USE='threads(+)'
+
inherit distutils-r1 git-r3
DESCRIPTION="Stand-alone Manifest generation & verification tool"
@@ -18,21 +20,14 @@ KEYWORDS=""
IUSE="+blake2 bzip2 +gpg lzma sha3 test tools"
RESTRICT="!test? ( test )"
-MODULE_RDEPEND="
+RDEPEND="
blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_5} pypy{,3}) )
bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
gpg? ( app-crypt/gnupg )
lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_5} pypy) )"
-RDEPEND="${MODULE_RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND=">=dev-python/setuptools-34[${PYTHON_USEDEP}]
- test? ( ${MODULE_RDEPEND} )"
-
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py
python_install_all() {
distutils-r1_python_install_all