summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-07 20:15:40 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-03-07 20:20:02 +0100
commitb9ae899eef2fec8653cedcf27f780be1ab31f80d (patch)
treec5065dcd303fc616e1acccf10fd8dcbb9d26f009 /app-portage
parentwww-servers/nginx-unit: enable py3.12 (diff)
downloadgentoo-b9ae899eef2fec8653cedcf27f780be1ab31f80d.tar.gz
gentoo-b9ae899eef2fec8653cedcf27f780be1ab31f80d.tar.bz2
gentoo-b9ae899eef2fec8653cedcf27f780be1ab31f80d.zip
app-portage/command-not-found: add 0.0.4
In preparation for app-portage/pfl version 3.5, this pfl release will make command-not-found almost twice as fast. Featuring https://github.com/AndrewAmmerlaan/command-not-found-gentoo/pull/2 by @bananas-repos Co-authored-by: Banana <76788321+bananas-repos@users.noreply.github.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/command-not-found/Manifest1
-rw-r--r--app-portage/command-not-found/command-not-found-0.0.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-portage/command-not-found/Manifest b/app-portage/command-not-found/Manifest
index 0f82dbf657c9..d135f311e978 100644
--- a/app-portage/command-not-found/Manifest
+++ b/app-portage/command-not-found/Manifest
@@ -1 +1,2 @@
DIST command-not-found-0.0.3.tar.gz 9534 BLAKE2B 6505e2de7c093b1ac1e4b056addbab9770bd9fedced12b54f454cd56be29d162ef7f14eea91c855aaf95249bb75af7fe36ca079646c5ca9f8aa8580d5036f796 SHA512 e36309f0e609b7fb607abeca79411d6c998f6c6c7f5769b0a0e72e0e44e4b90af550b5df0b22b94d8151751728b0ef0206ff13d1dd5d0262538c28c563f4b5e6
+DIST command-not-found-0.0.4.tar.gz 10028 BLAKE2B b1740a01400ed0084ad22414a586926132d6c9e6994de50812cf885d947c4bd95e65d715bcbc8b13f173464a7896ff6b8ee95782ab8a18d5884aa338bffa28ae SHA512 1c0ed9d17f7cfa18b8d1a8fd914716f6e44dd514f79e92ea8d33e4b0ee8d2556ee23b8853d286993fe72a1bdf23fc656f276fe8264bf78fef83f045169efe7c2
diff --git a/app-portage/command-not-found/command-not-found-0.0.4.ebuild b/app-portage/command-not-found/command-not-found-0.0.4.ebuild
new file mode 100644
index 000000000000..1859d6690bfe
--- /dev/null
+++ b/app-portage/command-not-found/command-not-found-0.0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit optfeature python-r1
+
+DESCRIPTION="Command-not-found handler for Gentoo"
+HOMEPAGE="https://github.com/AndrewAmmerlaan/command-not-found-gentoo"
+SRC_URI="https://github.com/AndrewAmmerlaan/command-not-found-gentoo/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_foreach_impl python_doscript command-not-found
+
+ insinto /etc/bash/bashrc.d
+ doins command-not-found.sh
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} is automatically setup for app-shells/bash, see"
+ elog " /usr/share/doc/${PF}/README.md"
+ elog "for instructions on how to set it up for various other shells."
+ elog
+ optfeature "suggesting snaps providing the missing command" "app-containers/snapd"
+ optfeature "suggesting ebuilds providing the missing command" "app-portage/pfl"
+}