summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-03-20 16:50:28 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-03-20 16:58:31 -0400
commitc4ba3ca4f9b9a15e3f8107698ab3458f0116af96 (patch)
tree43a163fbedc631ebadc83e4400fd012774b98d20 /app-portage
parentdev-games/godot: add 4.0.1 (diff)
downloadgentoo-c4ba3ca4f9b9a15e3f8107698ab3458f0116af96.tar.gz
gentoo-c4ba3ca4f9b9a15e3f8107698ab3458f0116af96.tar.bz2
gentoo-c4ba3ca4f9b9a15e3f8107698ab3458f0116af96.zip
app-portage/iwdevtools: add 0.12.4, straight-to-stable
No code changes, only minor config files additions -- not really worth going through stabilization process. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/iwdevtools/Manifest1
-rw-r--r--app-portage/iwdevtools/iwdevtools-0.12.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/app-portage/iwdevtools/Manifest b/app-portage/iwdevtools/Manifest
index c473f800db87..fe573f034eae 100644
--- a/app-portage/iwdevtools/Manifest
+++ b/app-portage/iwdevtools/Manifest
@@ -1 +1,2 @@
DIST iwdevtools-0.12.3.tar.gz 89745 BLAKE2B 7d52bd59fcc98cff28873dd8d7737b1e75a99111ea27dac6803d2a14975eb04dc5be88a03e6efd46eef6662828453fc7c53afc9c920d82e74b44fd1e837e58df SHA512 f2efdce89350f85d2c77c7df9fa5fde62ac2923b5cc36eedd4c6ce507fbbe12f915e138a16c8b6b360f093057118a274844c112158ce01bb3f456a415b222216
+DIST iwdevtools-0.12.4.tar.gz 89925 BLAKE2B 6fd87cc528784d443cf966fd126f4bcb020bbaf759509eb1d3e512af73d16fc22b12de06510d2486fcb96ff8c86f8fc77d404d55b2935ef0b456f582a007d903 SHA512 c6486a16ade37a98f38e551e8c01c19c1704b1d99cef87fd1bff9575dcb52df6a1429a2fc26783cbcdc64c971f4885286e9155786a8aa23360c32826e6b8f19e
diff --git a/app-portage/iwdevtools/iwdevtools-0.12.4.ebuild b/app-portage/iwdevtools/iwdevtools-0.12.4.ebuild
new file mode 100644
index 000000000000..ad9fe2c7e81b
--- /dev/null
+++ b/app-portage/iwdevtools/iwdevtools-0.12.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature
+
+DESCRIPTION="Small tools to aid with Gentoo development, primarily intended for QA"
+HOMEPAGE="https://github.com/ionenwks/iwdevtools"
+SRC_URI="https://github.com/ionenwks/iwdevtools/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-misc/pax-utils
+ app-portage/portage-utils
+ >=app-shells/bash-5.1
+ dev-libs/libxml2:2
+ sys-apps/coreutils
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/portage
+ || ( sys-apps/util-linux app-misc/getopt )"
+BDEPEND="
+ sys-apps/help2man
+ || ( sys-apps/util-linux app-misc/getopt )
+ test? ( ${RDEPEND} )"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir=${PF}
+ -Deprefix="${EPREFIX}"
+ -Dshellcheck=false
+ $(meson_use test)
+ )
+
+ has_version sys-apps/util-linux || emesonargs+=( -Dgetopt=getopt-long )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature "detecting potential ABI issues using abidiff" dev-util/libabigail
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Optional portage integration relies on using /etc/portage/bashrc."
+ elog "The example bashrc can be used as-is if not already using one:"
+ elog
+ elog " ln -s ../../usr/share/${PN}/bashrc ${EROOT}/etc/portage/bashrc"
+ elog
+ elog "Otherwise, inspect the tools' --help output and the example to integrate"
+ elog "(if not defining the same phase functions, the example can be sourced)."
+ elog
+ elog "Note that \`eqawarn\` is used for portage output by default. QA messages"
+ elog "aren't logged / shown post-emerge unless e.g. in /etc/portage/make.conf:"
+ elog
+ elog ' PORTAGE_ELOG_CLASSES="${PORTAGE_ELOG_CLASSES} qa"'
+ elog
+ elog "See ${EROOT}/usr/share/doc/${PF}/README.rst* for information on tools."
+ fi
+}