summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-17 11:44:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-17 11:44:43 +0200
commitcea6b8c9a93b006689bd4637f41cd8ba9d2497a5 (patch)
treed87231c5ca60a9d5c164e92351cd0ef1629e6267 /app-portage
parentpython-utils-r1.eclass: Loosen minimal Python versions (diff)
downloadgentoo-cea6b8c9a93b006689bd4637f41cd8ba9d2497a5.tar.gz
gentoo-cea6b8c9a93b006689bd4637f41cd8ba9d2497a5.tar.bz2
gentoo-cea6b8c9a93b006689bd4637f41cd8ba9d2497a5.zip
app-portage/flaggie: Bump to 0.99.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/flaggie/Manifest1
-rw-r--r--app-portage/flaggie/flaggie-0.99.5.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/flaggie/Manifest b/app-portage/flaggie/Manifest
index c84233964db5..27fc5ab8a393 100644
--- a/app-portage/flaggie/Manifest
+++ b/app-portage/flaggie/Manifest
@@ -1,2 +1,3 @@
DIST flaggie-0.2.1.tar.bz2 16767 BLAKE2B fea0fbc505bfa97e7bee2c05f0cc19077b9b23a021b01aafa2c4b064466677f9dd4ae95c36f6de65b4ad07c5046d539ceb0cb667dcb791b60410d7a5e688813f SHA512 3f273ebeceaaedce7a3807126fb3f450e420338a883440066d06a4d6a95b63bd538bb5da882fea23e0d390b28a83f50375dbda2624f656327775b2b700f2b2e4
DIST flaggie-0.99.4.tar.gz 17731 BLAKE2B 460993edfad7dc13206c6ab96919a74a306534f69b5c2971c9bc4289e964052888c93ff4b935fdf722fc7490a250b33c9644472749b2dc060e7dfd0b0d8dacf3 SHA512 0a2225470a6cc1ee72d7c33abe40cae48b698ac24e0456f9e59bcfd04769c9c01154c62c9fbc2d384d086db06f8a9d76e0cefe761a18669fcbe8ae3bee495b92
+DIST flaggie-0.99.5.tar.gz 17792 BLAKE2B 0400d08383e80b7543fc18afa8d63e68d5b889327db119f53fb5b9f74959a10f5d918c9e284c590b403f30197275f0833b51313729b125c1f4e0feba8113afb7 SHA512 77e7b66148bb3779bf2f89507834ebcb587ad822126b282da9fea5361f4df54e6cd9a18311d23de8648ab6aba2e4aa18686296bfab9ae3823a4435252e431c7f
diff --git a/app-portage/flaggie/flaggie-0.99.5.ebuild b/app-portage/flaggie/flaggie-0.99.5.ebuild
new file mode 100644
index 000000000000..171f784597fe
--- /dev/null
+++ b/app-portage/flaggie/flaggie-0.99.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="
+ https://github.com/projg2/flaggie/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=app-portage/gentoopm-0.5.0[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-vcs/git
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ ewarn "This is a preview release of flaggie 1.x. It it not fully featured"
+ ewarn "yet and it may have significant bugs. Please back your /etc/portage"
+ ewarn "up before using it. Verify the results using --pretend."
+}