summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-24 16:27:38 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-24 16:28:15 +0200
commitdc79d10d37c16ef16f655e678f654ba23160fa4b (patch)
treed3bf366efced61e51e995a20197df5e9db1651e2 /app-portage
parentapp-i18n/fcitx-unikey: Use cmake.eclass. (diff)
downloadgentoo-dc79d10d37c16ef16f655e678f654ba23160fa4b.tar.gz
gentoo-dc79d10d37c16ef16f655e678f654ba23160fa4b.tar.bz2
gentoo-dc79d10d37c16ef16f655e678f654ba23160fa4b.zip
app-portage/gemato: Revert "Remove old"
Reverts: 7f810fa2fe564c4762bdd7aa493c2bd7f927aa0e Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest2
-rw-r--r--app-portage/gemato/gemato-14.4-r1.ebuild33
-rw-r--r--app-portage/gemato/gemato-14.5.ebuild33
3 files changed, 68 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index c941dc67c94f..b446bc7d81b1 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1,2 +1,4 @@
+DIST gemato-14.4.tar.gz 72630 BLAKE2B c8956b979d7c8629e245ba339e8ee707cd51ffe545a85c712c31b97ee2aaabef7a4964cac46c9cd8c4954c33529623293a94a26ae40b578a6b640aab15d47835 SHA512 0b514e4ff7773eefd2d9adc063a4fbc6a1e7d9ea3dfa783b1d5a8e6ec1e482533a8c70cd5e200a8b9671161d77e14254ad14aee6659e3c96eb9be3bbedcf11af
+DIST gemato-14.5.tar.gz 72752 BLAKE2B 61ca43c92556850afdc8ab1d027aa719d13e77727caf9660d1861b1cb07ab40c05bd0fab23f99eaa47252e09465813685c59d1ebb5cc89c2c3381e1571256836 SHA512 0979de8cb4fc51c79d5af485092e0b376094238d6bb67d44db96c66b1d5ee945f0ba82dc6f72bea1042b935029cb790c5cd87bc419ba82da21a972141f3690bb
DIST gemato-15.2.tar.gz 72679 BLAKE2B 83e28fa3bc83976538610fec87c3a31e91a18847c107dc7793e16b5421eba69f7b60f8f05195f345ef6f4f8486203e4acbc01bad706b55c20a11480e85a3420c SHA512 5a98040dab0beac64e5e54bd54c6565cd301399709beda9e030ae9206111caf9e792260aa3c6586040060d4be71df3f1368e7554dff6affaa899c4157116faf3
DIST gemato-16.1.tar.gz 79946 BLAKE2B 54452ae113cee98f5c8f9ebc880b4ae424510766eb7cd8bc2775c85573388005343061aa9de8f505a72ee92801756f3cb7b67dfd39d9923d0030a4da301f7ce2 SHA512 df21eb8784cc6724874e38ba0192e1e5657483aa031656855fc0c2396179f7352f9450df6b41205425214cf70f2c812a7ee6f55a25334f0fd012b7e710c1de2c
diff --git a/app-portage/gemato/gemato-14.4-r1.ebuild b/app-portage/gemato/gemato-14.4-r1.ebuild
new file mode 100644
index 000000000000..988fd3f61f4f
--- /dev/null
+++ b/app-portage/gemato/gemato-14.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg tools"
+
+RDEPEND="
+ gpg? ( >=app-crypt/gnupg-2.2.20-r1 )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}
diff --git a/app-portage/gemato/gemato-14.5.ebuild b/app-portage/gemato/gemato-14.5.ebuild
new file mode 100644
index 000000000000..a3227bbf179d
--- /dev/null
+++ b/app-portage/gemato/gemato-14.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg tools"
+
+RDEPEND="
+ gpg? ( >=app-crypt/gnupg-2.2.20-r1 )"
+
+distutils_enable_tests setup.py
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}