summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-08-16 13:48:31 -0700
committerZac Medico <zmedico@gentoo.org>2020-08-16 13:54:03 -0700
commite14213a0eff6711e61225a95807e51ec329196cc (patch)
tree82c5ddbb74adf5a732e64912783363d316d27e93 /app-portage
parentMasked dev-ada packages until python3 compliant (diff)
downloadgentoo-e14213a0eff6711e61225a95807e51ec329196cc.tar.gz
gentoo-e14213a0eff6711e61225a95807e51ec329196cc.tar.bz2
gentoo-e14213a0eff6711e61225a95807e51ec329196cc.zip
app-portage/esearch: 1.3-r3 for bug 670224
#670224 fix esearchdb.py quoting Closes: https://bugs.gentoo.org/670224 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/esearch/esearch-1.3-r3.ebuild (renamed from app-portage/esearch/esearch-1.3-r2.ebuild)5
-rw-r--r--app-portage/esearch/files/1.3-updatedb-quoting.patch39
2 files changed, 42 insertions, 2 deletions
diff --git a/app-portage/esearch/esearch-1.3-r2.ebuild b/app-portage/esearch/esearch-1.3-r3.ebuild
index 39ad2fc4e7f2..026f4017bec1 100644
--- a/app-portage/esearch/esearch-1.3-r2.ebuild
+++ b/app-portage/esearch/esearch-1.3-r3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7})
+PYTHON_COMPAT=(python3_{6..9})
PYTHON_REQ_USE="readline(+)"
inherit distutils-r1
@@ -27,6 +27,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PV}-Fix-setup.py.patch
"${FILESDIR}"/${PV}-Fix-python-3-compatability.patch
+ "${FILESDIR}"/${PV}-updatedb-quoting.patch
)
python_configure_all() {
diff --git a/app-portage/esearch/files/1.3-updatedb-quoting.patch b/app-portage/esearch/files/1.3-updatedb-quoting.patch
new file mode 100644
index 000000000000..4f20634e6750
--- /dev/null
+++ b/app-portage/esearch/files/1.3-updatedb-quoting.patch
@@ -0,0 +1,39 @@
+From 8cbf59309a48327b74969bf402b415e389d79f73 Mon Sep 17 00:00:00 2001
+From: Zac Medico <zmedico@gentoo.org>
+Date: Sun, 16 Aug 2020 13:37:27 -0700
+Subject: [PATCH] updatedb: use repr for correct quoting (bug 670224)
+
+Bug: https://bugs.gentoo.org/670224
+Signed-off-by: Zac Medico <zmedico@gentoo.org>
+---
+ esearch/update.py | 12 ++----------
+ 1 file changed, 2 insertions(+), 10 deletions(-)
+
+diff --git a/esearch/update.py b/esearch/update.py
+index f05d08f..b18070c 100755
+--- a/esearch/update.py
++++ b/esearch/update.py
+@@ -210,18 +210,10 @@ def updatedb(config=None):
+ lastcat = curcat
+
+ installed = pkg_version(VARTREE.dep_bestmatch(pkg))
+- if installed:
+- installed = "\'%s\'" % installed
+- else:
+- installed = str(installed)
+
+ dbfile.write(
+- _unicode(
+- "(\'%s\', \'%s\', %s" %(pkgname, pkg, str(masked)) +
+- ", \'%s\', %s" % (pkg_version(pkgv), installed) +
+- ", \'%s\', \'%s\', \'%s\', \'%s\'"
+- % (filesize, homepage, description.replace("'", "\\'"),
+- _license) + "),\n"))
++ repr((pkgname, pkg, masked, pkg_version(pkgv), installed,
++ filesize, homepage, description, _license)) + ",\n")
+
+ except KeyboardInterrupt:
+ dbfile.close()
+--
+2.25.3
+