summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-12-03 10:50:29 +0100
committerMichał Górny <mgorny@gentoo.org>2017-12-03 11:39:55 +0100
commite57a1302ad78c492657551462f77b141e642acd2 (patch)
tree986c8ba59f3f3086b06e271f113e3e7304a2ab33 /app-portage
parentnet-wireless/wpa_supplicant: Don't show elog messages always (#548210) (diff)
downloadgentoo-e57a1302ad78c492657551462f77b141e642acd2.tar.gz
gentoo-e57a1302ad78c492657551462f77b141e642acd2.tar.bz2
gentoo-e57a1302ad78c492657551462f77b141e642acd2.zip
app-portage/gemato: Bump to 9.1
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-9.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 46cb856ef8ab..10045397b4a5 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-8.tar.gz 57379 BLAKE2B e83cba508ed781667abab3e18059f838c99e92217a7f1dde90b2cc4200a0ab83baabf789bc6bc978b4f080bf285ab9b7ea62e86a98c272abf3889093d780eac3 SHA512 9e5e7c304166d311b7101330b36c3d781e5d3901feb5247235ed04a8aa316416f6045658fab176e34ca6c2d6653eda66ef19789b39a60cb316add9985c9a8040
+DIST gemato-9.1.tar.gz 59352 BLAKE2B e2e2d02de29856a91c2432496101589fbe1a87456d46071c03ae5b999a46356f144c6d5831d42896ee15d1bdede32cdcc6b02c412b427f7878d8fc9ecaef84c1 SHA512 cf7bec8ccf7eab75bdbaf0e9a701c7b0fa1a8f2f329f4ba7ef3399898997a6bb3f53c6dfe49cd054ce12baf1f4490e2b7610f5964ff7e6053ae7dd53dd34900e
diff --git a/app-portage/gemato/gemato-9.1.ebuild b/app-portage/gemato/gemato-9.1.ebuild
new file mode 100644
index 000000000000..b6774a8be338
--- /dev/null
+++ b/app-portage/gemato/gemato-9.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# backports.lzma is broken with pypy
+# pyblake2 & pysha3 are broken with pypy3
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="https://github.com/mgorny/gemato"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+blake2 bzip2 +gpg lzma sha3"
+
+RDEPEND="
+ blake2? ( $(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )
+ bzip2? ( $(python_gen_cond_dep 'dev-python/bz2file[${PYTHON_USEDEP}]' python2_7 pypy) )
+ gpg? ( app-crypt/gnupg )
+ lzma? ( $(python_gen_cond_dep 'dev-python/backports-lzma[${PYTHON_USEDEP}]' python2_7 pypy) )
+ sha3? ( $(python_gen_cond_dep 'dev-python/pysha3[${PYTHON_USEDEP}]' python{2_7,3_4,3_5} pypy{,3}) )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}