summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-19 12:35:40 +0100
committerSam James <sam@gentoo.org>2023-08-19 12:36:49 +0100
commitf0eeecbd89691ecbec236d3f40a9b5df90faa0de (patch)
tree9de0faf67a98e94a97644d2b68322c1398bb1dda /app-portage
parentvirtual/secret-service: update comment re: the KDE provider (diff)
downloadgentoo-f0eeecbd89691ecbec236d3f40a9b5df90faa0de.tar.gz
gentoo-f0eeecbd89691ecbec236d3f40a9b5df90faa0de.tar.bz2
gentoo-f0eeecbd89691ecbec236d3f40a9b5df90faa0de.zip
app-portage/getuto: add 9999
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/getuto/Manifest1
-rw-r--r--app-portage/getuto/getuto-9999.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-portage/getuto/Manifest b/app-portage/getuto/Manifest
index 60dd545800a6..a50e57772012 100644
--- a/app-portage/getuto/Manifest
+++ b/app-portage/getuto/Manifest
@@ -1 +1,2 @@
DIST getuto-1.0.tar.gz 8218 BLAKE2B 9579bce48cb746db6aabe13b1e809ec73ddd1ea6ed859bbe5b6b860659a2e3747dc8f408c67531854ba6b7f4aa6fc31ac788122eb30d2100213176777d2ca4b3 SHA512 b6de03eef95802d678504321f37093a491a17673ae31b03834bc29a85815aab593fd7e2fe396ac21b83e804939932557c99e69d94d0599e2dbbfb410e1708e2e
+DIST libc-1-r1-1.gpkg.tar 20480 BLAKE2B b2c184e20c1a29ff66240e992f9f81219285f525eb63cea081372685cf03a2e231a2edb528259617e74c655fbe61b6e0d8fc0bbdbd8452b6098de58432f019d7 SHA512 ce52f398ea8979ec16161381803740d49a4294c77303880f54090c379ba5eb8e545a3d3550f229cacc18c7763dc3adf7936561ba1c64b43c87692ec66084e4e6
diff --git a/app-portage/getuto/getuto-9999.ebuild b/app-portage/getuto/getuto-9999.ebuild
new file mode 100644
index 000000000000..e73fa00ef161
--- /dev/null
+++ b/app-portage/getuto/getuto-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Stand-alone gentoo install trust anchor generation tool"
+HOMEPAGE="https://github.com/projg2/getuto"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/projg2/getuto"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/projg2/getuto/archive/refs/tags/${P}.tar.gz
+ "
+ S=${WORKDIR}/${PN}-${P}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+=" test? ( https://mirror.bytemark.co.uk/gentoo/releases/amd64/binpackages/17.1/x86-64/virtual/libc/libc-1-r1-1.gpkg.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-crypt/gnupg
+ sec-keys/openpgp-keys-gentoo-release
+"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ # Don't mangle test data
+ unpack ${P}.tar.gz
+ fi
+
+ if use test ; then
+ cp "${DISTDIR}"/libc-1-r1-1.gpkg.tar "${S}" || die
+ fi
+}
+
+src_install() {
+ dobin getuto
+}