summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Joliet <marcec@gmx.de>2015-12-04 21:57:30 +0100
committerMarc Joliet <marcec@gmx.de>2015-12-04 22:00:22 +0100
commitd817c33d460afeda104ef7016f6e1bd9dd7dbf9f (patch)
treec6740dc5bda888c5b420e867d0aa2f683124f0ef /app-shells/autojump/autojump-22.2.4-r4.ebuild
parentapp-shells/autojump-22.2.4-r4: convert einfo to elog (diff)
downloadgentoo-d817c33d460afeda104ef7016f6e1bd9dd7dbf9f.tar.gz
gentoo-d817c33d460afeda104ef7016f6e1bd9dd7dbf9f.tar.bz2
gentoo-d817c33d460afeda104ef7016f6e1bd9dd7dbf9f.zip
app-shells/autojump-22.2.4-r4: python -> ipython
Rename the python USE flag to ipython, since it really controls IPython support, and not general Python support.
Diffstat (limited to 'app-shells/autojump/autojump-22.2.4-r4.ebuild')
-rw-r--r--app-shells/autojump/autojump-22.2.4-r4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-shells/autojump/autojump-22.2.4-r4.ebuild b/app-shells/autojump/autojump-22.2.4-r4.ebuild
index 6c967ce1d362..84bf29112be3 100644
--- a/app-shells/autojump/autojump-22.2.4-r4.ebuild
+++ b/app-shells/autojump/autojump-22.2.4-r4.ebuild
@@ -15,11 +15,11 @@ SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> $
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc ~ppc64"
-IUSE="python test"
+IUSE="ipython test"
# Not all tests pass. Need investigation.
RESTRICT="test"
-RDEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="ipython? ( ${PYTHON_DEPS} )"
DEPEND="test? ( dev-python/flake8 dev-python/tox )"
src_prepare() {
@@ -56,7 +56,7 @@ src_install() {
doins bin/_j
python_foreach_impl python_domodule bin/autojump_data.py bin/autojump_utils.py
- if use python; then
+ if use ipython; then
python_foreach_impl python_domodule tools/autojump_ipython.py
fi
@@ -65,7 +65,7 @@ src_install() {
}
pkg_postinst() {
- if use python; then
+ if use ipython; then
elog 'This tool provides "j" for ipython, please add'
elog '"import autojump_ipython" to your ipy_user_conf.py.'
elog