summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-04-09 08:51:26 -0700
committerMatt Turner <mattst88@gentoo.org>2019-04-09 09:10:08 -0700
commitc455eb27b86e4cbc6e744535456419d899e39374 (patch)
tree7cf7a6de67aec524cd4485637837c8a1716dec1a /app-shells/autojump/autojump-22.5.3.ebuild
parentxfce-extra/xfce4-vala: Support vala:0.42 (~arch) (diff)
downloadgentoo-c455eb27b86e4cbc6e744535456419d899e39374.tar.gz
gentoo-c455eb27b86e4cbc6e744535456419d899e39374.tar.bz2
gentoo-c455eb27b86e4cbc6e744535456419d899e39374.zip
app-shells/autojump: Version bump to 22.5.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-shells/autojump/autojump-22.5.3.ebuild')
-rw-r--r--app-shells/autojump/autojump-22.5.3.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/app-shells/autojump/autojump-22.5.3.ebuild b/app-shells/autojump/autojump-22.5.3.ebuild
new file mode 100644
index 000000000000..fe3883cf63eb
--- /dev/null
+++ b/app-shells/autojump/autojump-22.5.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit bash-completion-r1 python-r1 vcs-snapshot
+
+DESCRIPTION="change directory command that learns"
+HOMEPAGE="https://github.com/wting/autojump"
+SRC_URI="https://github.com/wting/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="ipython test"
+REQUIRED_USE="ipython? ( ${PYTHON_REQUIRED_USE} )"
+
+# Not all tests pass. Need investigation.
+RESTRICT="test"
+RDEPEND="ipython? ( ${PYTHON_DEPS} )"
+DEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ eapply_user
+ sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
+ -e "s:/usr/local/share:/usr/share:" \
+ -i bin/autojump.sh || die
+
+ # autojump_argparse is only there for Python 2.6 compatibility
+ sed -e "s:autojump_argparse:argparse:" \
+ -i bin/autojump || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin bin/"${PN}"
+ python_replicate_script "${ED}"/usr/bin/"${PN}"
+
+ insinto /etc/profile.d
+ doins bin/"${PN}".sh
+
+ insinto /usr/share/"${PN}"/
+ doins bin/"${PN}.bash"
+ doins bin/"${PN}.zsh"
+ doins bin/"${PN}.fish"
+ insinto /usr/share/zsh/site-functions
+ doins bin/_j
+
+ python_foreach_impl python_domodule bin/autojump_argparse.py bin/autojump_data.py \
+ bin/autojump_match.py bin/autojump_utils.py
+ if use ipython; then
+ python_foreach_impl python_domodule tools/autojump_ipython.py
+ fi
+
+ doman docs/"${PN}.1"
+ einstalldocs
+}
+
+pkg_postinst() {
+ if use ipython; then
+ elog 'This tool provides "j" for ipython, please add'
+ elog '"import autojump_ipython" to your ipy_user_conf.py.'
+ elog
+ fi
+
+ elog 'If you use app-shells/fish, add the following code to your'
+ elog 'config.fish to get autojump support:'
+ elog 'if test -f /usr/share/autojump/autojump.fish'
+ elog ' source /usr/share/autojump/autojump.fish'
+ elog 'end'
+}