summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-08-18 21:36:34 -0700
committerMatt Turner <mattst88@gentoo.org>2020-08-18 21:38:16 -0700
commit93ec289e60f1a74adc57bef9dc673b6af2f8dff2 (patch)
treec9afd77d7cdec78ce9f36c008ff4b98e54f62c4d /app-shells/autojump
parentapp-shells/autojump: Add Python 3.8 compatibility (diff)
downloadgentoo-93ec289e60f1a74adc57bef9dc673b6af2f8dff2.tar.gz
gentoo-93ec289e60f1a74adc57bef9dc673b6af2f8dff2.tar.bz2
gentoo-93ec289e60f1a74adc57bef9dc673b6af2f8dff2.zip
app-shells/autojump: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/Manifest2
-rw-r--r--app-shells/autojump/autojump-22.2.4-r4.ebuild83
-rw-r--r--app-shells/autojump/autojump-22.5.1.ebuild76
-rw-r--r--app-shells/autojump/files/autojump-22.2.4-fix-__aj_error-typo.patch22
-rw-r--r--app-shells/autojump/files/autojump-22.2.4-fix-autojump.fish-bugs.patch67
5 files changed, 0 insertions, 250 deletions
diff --git a/app-shells/autojump/Manifest b/app-shells/autojump/Manifest
index 6127b32c7a82..02b5487c4dba 100644
--- a/app-shells/autojump/Manifest
+++ b/app-shells/autojump/Manifest
@@ -1,3 +1 @@
-DIST autojump-22.2.4.tar.gz 52724 BLAKE2B 42d5db90d4a29c63f5cd79437ca005f9f6382a607ab9284244fd6bbcf539509c5043df71ab305a5e8420ec225f8d651411d327833762737e0a5ad828ac021d2b SHA512 bdfca07bb57b3a2733a2085af14f23c3e980b1b00db1c90247c2341ac73f60f171bdde29dd9917aac0808d0b8f2902d48096c990e09281745a71755f5abc921c
-DIST autojump-22.5.1.tar.gz 54721 BLAKE2B ea3a852dddc13ece5ff177be0b3f384e5dcb19795d31d22edae90dba19fe3e78a4b78f48f08c338521d89d57af6251d5690c62eab445229812adb154286b0d5c SHA512 ed1bb28b62d14a481d5c8ee8ebbfc286d21ca54c961904f81ac123c784e17810217dfe1689bdd4b50fd7a9d72509c0cb13583a9817074f6afe26dc3144f64243
DIST autojump-22.5.3.tar.gz 55429 BLAKE2B 3a2773669f81d1a54c01cce9fe75bc01609265998b035b4ba1aa064f1132acf852b59eb04ebfa744e628152f0ab478cbef24e5aff326bf84cec6e2c9348e8360 SHA512 d1dd3cbb67fda4e0a17ec5028b947faf46be8a95a6cd8418127b927f42bc95b71538a06658b38b479c77d147a6cd5e8cef77639ef538c7d449414c469c13f140
diff --git a/app-shells/autojump/autojump-22.2.4-r4.ebuild b/app-shells/autojump/autojump-22.2.4-r4.ebuild
deleted file mode 100644
index cbaa265735d3..000000000000
--- a/app-shells/autojump/autojump-22.2.4-r4.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit bash-completion-r1 python-r1 vcs-snapshot
-
-DESCRIPTION="change directory command that learns"
-HOMEPAGE="https://github.com/joelthelion/autojump"
-SRC_URI="https://github.com/joelthelion/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="ipython test"
-REQUIRED_USE="ipython? ( ${PYTHON_REQUIRED_USE} )"
-
-# Not all tests pass. Need investigation.
-RESTRICT="test"
-RDEPEND="ipython? ( ${PYTHON_DEPS} )"
-DEPEND="test? ( dev-python/flake8 dev-python/tox )"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-autojump.fish-bugs.patch"
- "${FILESDIR}/${P}-fix-__aj_error-typo.patch"
-)
-
-src_prepare() {
- sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
- -e "s:/usr/local/share:/usr/share:" \
- -i bin/autojump.sh || die
-
- # autojump_argparse is only there for Python 2.6 compatibility
- sed -e "s:autojump_argparse:argparse:" \
- -i bin/autojump || die
-
- # upstream fixes to the autojump.fish script; the first patch is needed for
- # the second patch to apply
- epatch "${PATCHES[@]}"
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- dobin bin/"${PN}"
- python_replicate_script "${ED}"/usr/bin/"${PN}"
-
- insinto /etc/profile.d
- doins bin/"${PN}".sh
-
- insinto /usr/share/"${PN}"/
- doins bin/"${PN}.bash"
- doins bin/"${PN}.zsh"
- doins bin/"${PN}.fish"
- insinto /usr/share/zsh/site-functions
- doins bin/_j
-
- python_foreach_impl python_domodule bin/autojump_data.py bin/autojump_utils.py
- if use ipython; then
- python_foreach_impl python_domodule tools/autojump_ipython.py
- fi
-
- doman docs/"${PN}.1"
- dodoc README.md
-}
-
-pkg_postinst() {
- if use ipython; then
- elog 'This tool provides "j" for ipython, please add'
- elog '"import autojump_ipython" to your ipy_user_conf.py.'
- elog
- fi
-
- elog 'If you use app-shells/fish, add the following code to your'
- elog 'config.fish to get autojump support:'
- elog 'if test -f /usr/share/autojump/autojump.fish'
- elog ' source /usr/share/autojump/autojump.fish'
- elog 'end'
-}
diff --git a/app-shells/autojump/autojump-22.5.1.ebuild b/app-shells/autojump/autojump-22.5.1.ebuild
deleted file mode 100644
index 245a0758bb79..000000000000
--- a/app-shells/autojump/autojump-22.5.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit bash-completion-r1 python-r1 vcs-snapshot
-
-DESCRIPTION="change directory command that learns"
-HOMEPAGE="https://github.com/wting/autojump"
-SRC_URI="https://github.com/wting/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~x64-macos"
-IUSE="ipython test"
-REQUIRED_USE="ipython? ( ${PYTHON_REQUIRED_USE} )"
-
-# Not all tests pass. Need investigation.
-RESTRICT="test"
-RDEPEND="ipython? ( ${PYTHON_DEPS} )"
-DEPEND="${PYTHON_DEPS}"
-
-src_prepare() {
- eapply_user
- sed -e "s: \(/etc/profile.d\): \"${EPREFIX}\1\":" \
- -e "s:/usr/local/share:/usr/share:" \
- -i bin/autojump.sh || die
-
- # autojump_argparse is only there for Python 2.6 compatibility
- sed -e "s:autojump_argparse:argparse:" \
- -i bin/autojump || die
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- dobin bin/"${PN}"
- python_replicate_script "${ED}"/usr/bin/"${PN}"
-
- insinto /etc/profile.d
- doins bin/"${PN}".sh
-
- insinto /usr/share/"${PN}"/
- doins bin/"${PN}.bash"
- doins bin/"${PN}.zsh"
- doins bin/"${PN}.fish"
- insinto /usr/share/zsh/site-functions
- doins bin/_j
-
- python_foreach_impl python_domodule bin/autojump_argparse.py bin/autojump_data.py \
- bin/autojump_match.py bin/autojump_utils.py
- if use ipython; then
- python_foreach_impl python_domodule tools/autojump_ipython.py
- fi
-
- doman docs/"${PN}.1"
- einstalldocs
-}
-
-pkg_postinst() {
- if use ipython; then
- elog 'This tool provides "j" for ipython, please add'
- elog '"import autojump_ipython" to your ipy_user_conf.py.'
- elog
- fi
-
- elog 'If you use app-shells/fish, add the following code to your'
- elog 'config.fish to get autojump support:'
- elog 'if test -f /usr/share/autojump/autojump.fish'
- elog ' source /usr/share/autojump/autojump.fish'
- elog 'end'
-}
diff --git a/app-shells/autojump/files/autojump-22.2.4-fix-__aj_error-typo.patch b/app-shells/autojump/files/autojump-22.2.4-fix-__aj_error-typo.patch
deleted file mode 100644
index 6a9ac3c83c8e..000000000000
--- a/app-shells/autojump/files/autojump-22.2.4-fix-__aj_error-typo.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From d188d7e6757a4d0cad619b6d5ab729fdc59b1593 Mon Sep 17 00:00:00 2001
-From: Scott Olson <scott@scott-olson.org>
-Date: Mon, 6 Jul 2015 23:12:35 -0400
-Subject: [PATCH] Fix typo (__aj_error -> __aj_err).
-
----
- bin/autojump.fish | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/bin/autojump.fish b/bin/autojump.fish
-index ead7ea1..b16ef01 100644
---- a/bin/autojump.fish
-+++ b/bin/autojump.fish
-@@ -91,7 +91,7 @@ function jo
- case cygwin
- cygstart "" (cygpath -w -a (pwd))
- case '*'
-- __aj_error "Unknown operating system: \"$OSTYPE\""
-+ __aj_err "Unknown operating system: \"$OSTYPE\""
- end
- else
- __aj_err "autojump: directory '"$argv"' not found"
diff --git a/app-shells/autojump/files/autojump-22.2.4-fix-autojump.fish-bugs.patch b/app-shells/autojump/files/autojump-22.2.4-fix-autojump.fish-bugs.patch
deleted file mode 100644
index 6048ca989376..000000000000
--- a/app-shells/autojump/files/autojump-22.2.4-fix-autojump.fish-bugs.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From f09d23e30d3159db18872a3e8f8f579ed9e77231 Mon Sep 17 00:00:00 2001
-From: David Frascone <David.Frascone@dishdigital.com>
-Date: Tue, 9 Jun 2015 14:32:38 -0600
-Subject: [PATCH] Fixed some bugs in fish script
-
-OSTYPE was not being set correctly. It is in bash, not sh.
- Since the value is unlikely to change, I read it once and
- stored it globally
-Test logic was backward in jo function, causing error to always
- be printed, unless you did NOT specify a directory name.
----
- bin/autojump.fish | 20 ++++++++++++--------
- 1 file changed, 12 insertions(+), 8 deletions(-)
-
-diff --git a/bin/autojump.fish b/bin/autojump.fish
-index 2cf5001..19cb27e 100644
---- a/bin/autojump.fish
-+++ b/bin/autojump.fish
-@@ -5,6 +5,11 @@ if test -d ~/.autojump
- set -x PATH ~/.autojump/bin $PATH
- end
-
-+# Set ostype, if not set
-+if not set -q OSTYPE
-+ set -gx OSTYPE (bash -c 'echo ${OSTYPE}')
-+end
-+
-
- # enable tab completion
- complete -x -c j -a '(autojump --complete (commandline -t))'
-@@ -34,7 +39,7 @@ end
- # misc helper functions
- function __aj_err
- # TODO(ting|#247): set error file location
-- echo $argv 1>&2; false
-+ echo -e $argv 1>&2; false
- end
-
- # default autojump command
-@@ -73,11 +78,7 @@ end
- function jo
- set -l output (autojump $argv)
- if test -d "$output"
-- __aj_err "autojump: directory '"$argv"' not found"
-- __aj_err "\n$output\n"
-- __aj_err "Try `autojump --help` for more information."
-- else
-- switch (sh -c 'echo ${OSTYPE}')
-+ switch $OSTYPE
- case 'linux*'
- xdg-open (autojump $argv)
- case 'darwin*'
-@@ -85,9 +86,12 @@ function jo
- case cygwin
- cygstart "" (cygpath -w -a (pwd))
- case '*'
-- __aj_error "Unknown operating system: '"$OSTYPE"'"
-+ __aj_error "Unknown operating system: \"$OSTYPE\""
- end
-- echo end
-+ else
-+ __aj_err "autojump: directory '"$argv"' not found"
-+ __aj_err "\n$output\n"
-+ __aj_err "Try `autojump --help` for more information."
- end
- end
-