summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-12-07 13:49:21 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-12-07 14:18:41 +0100
commit4c2ebbf4b8bc660beb98cc2d845c73375d6e4f50 (patch)
treed219dac97affc7a5782eb0ad7d7331c1a36b1a7e /app-shells/bash
parentdev-lang/lua: fix malformed lua-5.1.4-test.patch (diff)
downloadgentoo-4c2ebbf4b8bc660beb98cc2d845c73375d6e4f50.tar.gz
gentoo-4c2ebbf4b8bc660beb98cc2d845c73375d6e4f50.tar.bz2
gentoo-4c2ebbf4b8bc660beb98cc2d845c73375d6e4f50.zip
app-shells/bash: Fixed parallel make issue
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-shells/bash')
-rw-r--r--app-shells/bash/bash-5.1.ebuild1
-rw-r--r--app-shells/bash/files/bash-5.1-parallel_make.patch15
2 files changed, 16 insertions, 0 deletions
diff --git a/app-shells/bash/bash-5.1.ebuild b/app-shells/bash/bash-5.1.ebuild
index b99647b1aed7..5d6585b3abe7 100644
--- a/app-shells/bash/bash-5.1.ebuild
+++ b/app-shells/bash/bash-5.1.ebuild
@@ -103,6 +103,7 @@ src_prepare() {
touch -r . doc/* || die
eapply -p0 "${PATCHES[@]}"
+ eapply "${FILESDIR}/${PN}-5.1-parallel_make.patch"
eapply_user
}
diff --git a/app-shells/bash/files/bash-5.1-parallel_make.patch b/app-shells/bash/files/bash-5.1-parallel_make.patch
new file mode 100644
index 000000000000..b341a8a06e28
--- /dev/null
+++ b/app-shells/bash/files/bash-5.1-parallel_make.patch
@@ -0,0 +1,15 @@
+bashline.c:65:10: fatal error: builtins/builtext.h: No such file or directory
+ 65 | #include "builtins/builtext.h" /* for read_builtin */
+ | ^~~~~~~~~~~~~~~~~~~~~
+
+--- bash-5.1/Makefile.in
++++ bash-5.1/Makefile.in
+@@ -584,6 +584,8 @@
+ ls -l $(Program)
+ -$(SIZE) $(Program)
+
++$(CSOURCES): $(DEFDIR)/builtext.h
++
+ .build: $(SOURCES) config.h Makefile version.h $(VERSPROG)
+ @echo
+ @echo " ***********************************************************"