summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-07 03:17:52 -0500
committerMike Frysinger <vapier@gentoo.org>2016-12-07 03:17:52 -0500
commite8b779ed01be648a1094348d7b02ae7e0898a120 (patch)
tree39827afeda1220280caba059b3f53b40f99d23b8 /app-shells/bashdb/bashdb-4.4.0.92.ebuild
parentapp-shells/bashdb: hardcode path to debugger main #591994 (diff)
downloadgentoo-e8b779ed01be648a1094348d7b02ae7e0898a120.tar.gz
gentoo-e8b779ed01be648a1094348d7b02ae7e0898a120.tar.bz2
gentoo-e8b779ed01be648a1094348d7b02ae7e0898a120.zip
app-shells/bashdb: version bump to 4.4.0.92
Diffstat (limited to 'app-shells/bashdb/bashdb-4.4.0.92.ebuild')
-rw-r--r--app-shells/bashdb/bashdb-4.4.0.92.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-shells/bashdb/bashdb-4.4.0.92.ebuild b/app-shells/bashdb/bashdb-4.4.0.92.ebuild
new file mode 100644
index 000000000000..e48a511f0157
--- /dev/null
+++ b/app-shells/bashdb/bashdb-4.4.0.92.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_P="${PN}-${PV:0:3}-${PV:4}"
+DESCRIPTION="bash source code debugging"
+HOMEPAGE="http://bashdb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bashdb/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="!>=app-shells/bash-${PV:0:1}.$((${PV:2:1}+1))"
+
+S="${WORKDIR}/${MY_P}"
+
+# Unfortunately, not all tests pass. #276877
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ # We don't install this, so don't bother building it. #468044
+ sed -i 's:texi2html:true:' doc/Makefile.in || die
+}
+
+src_configure() {
+ # This path matches the bash sources. If we ever change bash,
+ # we'll probably have to change this to match. #591994
+ econf --with-dbg-main='$(PKGDATADIR)/bashdb-main.inc'
+}