summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-07-09 00:16:57 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-07-09 00:16:57 -0700
commita715cb755028ae898d05820715ca502acaf7241f (patch)
tree647442fd8c58ca26c7900e1972241ea935849583 /app-shells/ctypes-sh
parentdev-python/rst-linker: stable 2.0.0 for sparc, bug #731566 (diff)
downloadgentoo-a715cb755028ae898d05820715ca502acaf7241f.tar.gz
gentoo-a715cb755028ae898d05820715ca502acaf7241f.tar.bz2
gentoo-a715cb755028ae898d05820715ca502acaf7241f.zip
app-shells/ctypes-sh-1.2: Version bump
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-shells/ctypes-sh')
-rw-r--r--app-shells/ctypes-sh/Manifest2
-rw-r--r--app-shells/ctypes-sh/ctypes-sh-1.2.ebuild (renamed from app-shells/ctypes-sh/ctypes-sh-1.1.ebuild)27
-rw-r--r--app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch18
3 files changed, 14 insertions, 33 deletions
diff --git a/app-shells/ctypes-sh/Manifest b/app-shells/ctypes-sh/Manifest
index 4245ae130ff8..9e75c1e193fb 100644
--- a/app-shells/ctypes-sh/Manifest
+++ b/app-shells/ctypes-sh/Manifest
@@ -1 +1 @@
-DIST ctypes-sh-1.1.tar.gz 437637 BLAKE2B d4279812d613a771ed405499dc623fce5faa00c22e75067857cea0a31e4a36a1531f7b27a1edff89075961bf5e8183bf0787a703cb36c1a8cbd7c03d8a18710f SHA512 0e136f5b9fc342875d02b1087daed60eed46f411765538f185d1da61430205113db72994ecdb125aded3eae114b3f487e7af398c1326334efdd197ee7de18a61
+DIST ctypes-sh-1.2.tar.gz 475531 BLAKE2B 6fe00415244227629b952a0c18f9c95659a3fb22b9f17e109554f11084d27bf4c23eca5bfc49679b63367fa9fe74a20f206ac79955ed6588418033f37b776729 SHA512 23e9c30acc8ed5b4fe93fe1427c406e7c7b18067bbfc3f948126683910efc645cc69e426d771beb715148b54dffce75351b7773d8b54ac13f74d9787db8529f6
diff --git a/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild b/app-shells/ctypes-sh/ctypes-sh-1.2.ebuild
index e737d10f3e87..a64a6db88110 100644
--- a/app-shells/ctypes-sh/ctypes-sh-1.1.ebuild
+++ b/app-shells/ctypes-sh/ctypes-sh-1.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools toolchain-funcs
@@ -13,17 +13,16 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="virtual/libffi
- virtual/libelf
- app-arch/xz-utils
+RDEPEND="
app-arch/bzip2
- app-shells/bash[plugins]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${P}-makefile-fix.patch"
-)
+ app-arch/xz-utils
+ app-shells/bash[plugins(-)]
+ dev-libs/libffi
+ virtual/libelf
+"
+BDEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
src_prepare() {
default
@@ -31,9 +30,9 @@ src_prepare() {
}
src_test() {
- pushd test
+ pushd test >/dev/null || die
PATH="${S}:${PATH}" \
LD_LIBRARY_PATH="${S}/src/.libs" \
make CC="$(tc-getCC)" || die "make check failed"
- popd
+ popd > /dev/null || die
}
diff --git a/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch b/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch
deleted file mode 100644
index 9a2965a62bc5..000000000000
--- a/app-shells/ctypes-sh/files/ctypes-sh-1.1-makefile-fix.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-commit 5e305160cc219fa63658148e3d258cb62dd043a3
-Author: rtlanceroad <rtlanceroad@gmail.com>
-Date: Wed Jul 27 14:49:21 2016 +0800
-
- fix Makefile.am in src dir
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 8a9b682..71347bb 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -11,6 +11,6 @@ ctypes_la_LIBADD += libstruct.la
- noinst_LTLIBRARIES += libstruct.la
- noinst_HEADERS += struct/dutil.h struct/dwarves.h struct/elf_symtab.h struct/gobuffer.h struct/hash.h struct/list.h struct/rbtree.h struct/strings.h
- libstruct_la_SOURCES = struct/dutil.c struct/dwarves.c struct/gobuffer.c struct/struct.c struct/strings.c struct/dwarf_loader.c struct/dwarves_fprintf.c struct/elf_symtab.c struct/rbtree.c
--libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE
-+libstruct_la_CFLAGS = -std=gnu99 -D_GNU_SOURCE $(FFI_CFLAGS)
- libstruct_la_CPPFLAGS = -I../include -I../lib
- endif