summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-21 14:21:43 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-21 18:51:47 +0200
commit91338b2349f1421e8000efd8cc78a6ecfeec06b9 (patch)
treeacfb8b262d6d6070ba3bbddc0b7227b976d132a4 /app-shells/dsh/dsh-0.25.10-r1.ebuild
parentapp-shells/scsh: fix metadata.xml file. (diff)
downloadgentoo-91338b2349f1421e8000efd8cc78a6ecfeec06b9.tar.gz
gentoo-91338b2349f1421e8000efd8cc78a6ecfeec06b9.tar.bz2
gentoo-91338b2349f1421e8000efd8cc78a6ecfeec06b9.zip
app-shells/dsh: EAPI 6 bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-shells/dsh/dsh-0.25.10-r1.ebuild')
-rw-r--r--app-shells/dsh/dsh-0.25.10-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/dsh/dsh-0.25.10-r1.ebuild b/app-shells/dsh/dsh-0.25.10-r1.ebuild
new file mode 100644
index 000000000000..8d90bcca9f0f
--- /dev/null
+++ b/app-shells/dsh/dsh-0.25.10-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Distributed Shell"
+HOMEPAGE="http://www.netfort.gr.jp/~dancer/software/dsh.html.en"
+SRC_URI="http://www.netfort.gr.jp/~dancer/software/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~m68k-mint"
+IUSE="nls"
+
+DEPEND="dev-libs/libdshconfig"
+
+RDEPEND="
+ ${DEPEND}
+ virtual/ssh"
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/etc/dsh $(use_enable nls)
+}
+
+src_install() {
+ default
+ dodir /etc/dsh/group
+}