summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-21 22:03:54 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-21 22:06:15 +0100
commitaf0b31c0d377ca66978879e48574313a7170ae9e (patch)
tree2767b726ad1f15828944e8a43b4d0e782c9ad38f /app-shells/gash/gash-0.3.0.ebuild
parentdev-python/gevent: Stabilize 21.12.0 arm, #832289 (diff)
downloadgentoo-af0b31c0d377ca66978879e48574313a7170ae9e.tar.gz
gentoo-af0b31c0d377ca66978879e48574313a7170ae9e.tar.bz2
gentoo-af0b31c0d377ca66978879e48574313a7170ae9e.zip
app-shells/gash: new package; add version 0.3.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells/gash/gash-0.3.0.ebuild')
-rw-r--r--app-shells/gash/gash-0.3.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-shells/gash/gash-0.3.0.ebuild b/app-shells/gash/gash-0.3.0.ebuild
new file mode 100644
index 000000000000..e9394761cf3c
--- /dev/null
+++ b/app-shells/gash/gash-0.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="POSIX-compatible shell written in Guile Scheme"
+HOMEPAGE="https://savannah.nongnu.org/projects/gash/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+
+RDEPEND=">=dev-scheme/guile-2.0.0:="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/texinfo"
+
+# guile generates ELF files without use of C or machine code
+# It's a portage's false positive. bug #677600
+QA_PREBUILT='*[.]go'
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}