summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2018-03-02 14:27:26 -0600
committerWilliam Hubbs <williamh@gentoo.org>2018-03-02 14:27:49 -0600
commitfe86446eb3949042c11bb947ebaf5edf23d21e70 (patch)
treeab9aba02da32b4d0aee6c6ef7666970f516ecf92 /app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild
parentx11-wm/windowmaker: stable 0.95.8-r1 for sparc, bug #641172 (diff)
downloadgentoo-fe86446eb3949042c11bb947ebaf5edf23d21e70.tar.gz
gentoo-fe86446eb3949042c11bb947ebaf5edf23d21e70.tar.bz2
gentoo-fe86446eb3949042c11bb947ebaf5edf23d21e70.zip
app-shells/gentoo-bashcomp: 20180302 bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild')
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild
new file mode 100644
index 000000000000..c67590fe9873
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20180302.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ completionsdir="$(get_bashcompdir)" \
+ helpersdir="$(get_bashhelpersdir)" \
+ compatdir="${EPREFIX}/etc/bash_completion.d"
+}